1064 朋友数

1064 朋友数

如果两个整数各位数字的和是一样的,则被称为是“朋友数”,而那个公共的和就是它们的“朋友证号”。例如 123 和 51 就是朋友数,因为 1+2+3 = 5+1 = 6,而 6 就是它们的朋友证号。给定一些整数,要求你统计一下它们中有多少个不同的朋友证号。

输入格式:
输入第一行给出正整数 N。随后一行给出 N 个正整数,数字间以空格分隔。题目保证所有数字小于 10
​4
​​ 。

输出格式:
首先第一行输出给定数字中不同的朋友证号的个数;随后一行按递增顺序输出这些朋友证号,数字间隔一个空格,且行末不得有多余空格。

输入样例:
8
123 899 51 998 27 33 36 12
输出样例:
4
3 6 9 26

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<iostream>
#include<string>
#include<algorithm>
#include<vector> 
#include<set> 
using namespace std;
int main()
{
	set<int> st;
	int n,sum=0,a;
	cin>>n;
	while(n--){
		cin>>a;
		while(a){
			sum+=a%10;
			a/=10;
		}
		st.insert(sum);
		sum=0;
	}
	int num=0;
	cout<<st.size()<<endl;
	for(set<int>::iterator it=st.begin();it!=st.end();it++){
		cout<<*it;
		num++;
		if(num<st.size()){
			cout<<" ";
		}
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值