HDU - 6300 Triangle Partition 暴力 结构体

Training 2 - D题

Chiaki has 3n3n points p1,p2,…,p3np1,p2,…,p3n. It is guaranteed that no three points are collinear.

Chiaki would like to construct nn disjoint triangles where each vertex comes from the 3n3n points.

Input

There are multiple test cases. The first line of input contains an integer TT, indicating the number of test cases. For each test case:

The first line contains an integer nn (1≤n≤10001≤n≤1000) – the number of triangle to construct.

Each of the next 3n3n lines contains two integers xixi and yiyi (−109≤xi,yi≤109−109≤xi,yi≤109).

It is guaranteed that the sum of all nn does not exceed 1000010000.

Output

For each test case, output nn lines contain three integers ai,bi,ciai,bi,ci (1≤ai,bi,ci≤3n1≤ai,bi,ci≤3n) each denoting the indices of points the ii-th triangle use. If there are multiple solutions, you can output any of them.

Sample Input

1
1
1 2
2 3
3 5

Sample Output

1 2 3


#pragma warning (disable:4996)
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <cstring>
#include <string>
#include <cstdio>
#include <cmath>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#define inf 0X3f3f3f3f
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 3e3 + 5;

struct Node
{
	int x;
	int y;
	int num;
	Node(int xx, int yy, int n)
	{
		x = xx;
		y = yy;
		num = n;
	}
	friend bool operator<(Node a, Node b)
	{
		if (a.x == b.x)
			return a.y < b.y;
		return a.x < b.x;
	}
};
vector<Node> v;

int main()
{
	int T;
	scanf("%d", &T);
	while (T--)
	{
		int n;
		scanf("%d", &n);
		for (int i = 1; i <= 3 * n; i++)
		{
			int a, b;
			scanf("%d%d", &a, &b);
			v.push_back(Node(a, b, i));
		}
		sort(v.begin(), v.end());
		int i = 1, j = 2, k = 3;
		for (int i = 0; i < 3 * n; i += 3)
		{
			for (int j = 0; j < 3; j++)
				printf("%d ", v[i + j].num);
			printf("\n");
		}
		while (v.size())
			v.pop_back();
	}
}

思路:
简单排序后不用判断暴力输出即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值