计蒜客 - 41349 Fire-Fighting Hero 图单源最短路径 dijkstra邻接矩阵 缩边法

Training 6 - E题

This is an era of team success, but also an era of heroes. Throughout the ages, there have been numerous examples of using the few to defeat the many. There are VVV (Numbers 111 to VVV) fire-fighting points in ACM city. These fire-fighting points have EEE roads to communicate with each other. Among them, there is a fire-fighting hero in the SSS fire-fighting point, and the fire-fighting team is distributed in K fire-fighting points. If a fire-fighting point needs to be put out, the fire-fighting hero or the fire-fighting team must arrive as soon as possible, that is, to choose the shortest route to arrive. Today, our fire-fighting heroes want to challenge the fire-fighting team. The challenge is to: The maximum value of the shortest path for a fire-fighting hero to go to others fire-fighting points is compared with the maximum value of the shortest path for a fire-fighting team to go to others fire-fighting points from any point in their fire-fighting points. Because firefighting heroes are different and run faster, the maximum value of the shortest path they get should be discounted first, that is, multiplied by a coefficient of 1C\frac{1}{C}C1​, and then compared. The smaller one wins. Who is the real firefighter in this situation?Who is the real firefighter in this situation?

Input

The first line contains a positive integer T(1≤T≤10)T (1\le T \le 10)T(1≤T≤10), which indicates that there are TTT cases of test data.The format of each case of test data is as follows:Line 111 contains five positive integers V(1≤V≤1000)V (1 \le V \le 1000)V(1≤V≤1000), E(V−1≤E≤V∗V2)E (V-1 \le E \le \frac{V*V}{2})E(V−1≤E≤2V∗V​), S(1≤S≤V)S (1 \le S \le V)S(1≤S≤V), K(1≤K≤V)K (1\le K \le V)K(1≤K≤V) and C(1≤C≤10)C (1\le C\le 10)C(1≤C≤10), the meanings are shown above.Line 222 contains KKK positive integers, which in turn denotes the location number of the fire-fighting point where the fire-fighting team is located.In the next EEE line, three positive integers i,j(1≤i,j≤V)i, j (1 \le i, j \le V)i,j(1≤i,j≤V) and L(1≤L≤10000)L (1 \le L \le 10000)L(1≤L≤10000) per line. Represents a path, i,ji, ji,j as the endpoint (fire-fighting point), LLL as the length of the path.

Output

Each case of test data outputs one line, which is a integer. That is, the maximum value of the shortest path of the winner (If the fire hero wins, the maximum value before the discount should be output). A draw is also a victory for fire-fighting hero.

Sample Input

1
4 7 3 2 2
1 4
1 2 7
1 3 2
1 4 6
2 1 1
2 4 1
3 2 1
3 4 3

Sample Output

2

#pragma warning (disable:4996)
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <cstring>
#include <string>
#include <cstdio>
#include <cmath>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
#define inf 0X3f3f3f3f
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int M = 1e6 + 5;
const int maxn = 1e3 + 5;

int edge[maxn][maxn];
int d[maxn];
bool v[maxn];
int tot;
int n, m, s, k, c;
int point[maxn];

priority_queue<pair<int, int>> q;

void dijkstra()
{
	for (int i = 1; i < n; i++)
	{
		//重复进行n-1次
		int x = 0;
		//找到未标记节点中dist最小的
		for (int j = 1; j <= n; j++)
			if (!v[j] && (x == 0 || d[j] < d[x]))
				x = j;
		v[x] = 1;
		//用全局最小值点x更新其他节点
		for (int y = 1; y <= n; y++)
			d[y] = min(d[y], d[x] + edge[x][y]);
	}
}

int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d%d%d%d%d", &n, &m, &s, &k, &c);
		memset(edge, inf, sizeof(edge));
		for (int i = 1; i <= n; i++)
			edge[i][i] = 0;
		memset(point, 0, sizeof(point));
		for (int i = 1; i <= k; i++)
			scanf("%d", &point[i]);
		for (int i = 1; i <= m; i++)
		{
			int x, y, z;
			scanf("%d%d%d", &x, &y, &z);
			edge[x][y] = edge[y][x] = min(edge[x][y], z);
		}
		memset(d, inf, sizeof(d));
		memset(v, 0, sizeof(v));
		d[s] = 0;
		dijkstra();
		int hero = d[1];
		for (int i = 1; i <= n; i++)
			hero = max(hero, d[i]);

		memset(d, inf, sizeof(d));
		memset(v, 0, sizeof(v));
		for (int i = 1; i <= k; i++)
			d[point[i]] = 0;
		dijkstra();
		int team = d[1];
		for (int i = 1; i <= n; i++)
			team = max(team, d[i]);

		if (hero <= c * team)
			printf("%d\n", hero);
		else
			printf("%d\n", team);
	}
	return 0;
}

思路:
一边dijkstra计算英雄消防员距离所有其他节点的最短距离;一边dijkstra计算消防队所在的节点距离其他所有节点的最短距离。dijkstra初始化是将起始节点的d[i]数组的值置为0。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值