描述
给出平面上4条线段,判断这4条线段是否恰好围成一个面积大于0的矩形。
输入
输入第一行是一个整数T(1<=T<=100),代表测试数据的数量。
每组数据包含4行,每行包含4个整数x1, y1, x2, y2 (0 <= x1, y1, x2, y2 <= 100000);其中(x1, y1), (x2,y2)代表一条线段的两个端点。
输出
每组数据输出一行YES或者NO,表示输入的4条线段是否恰好围成矩形。
样例输入
3
0 0 0 1
1 0 1 1
0 1 1 1
1 0 0 0
0 1 2 3
1 0 3 2
3 2 2 3
1 0 0 1
0 1 1 0
1 0 2 0
2 0 1 1
1 1 0 1
样例输出
YES
YES
NO
题解
对于一个矩形,四条线段两两之间,共有4个平行关系,8个垂直关系。
#include <bits/stdc++.h>
using namespace std;
struct Line{
int x1, y1, x2, y2;
Line(int x1, int y1, int x2, int y2):x1(x1), y1(y1), x2(x2), y2(y2){}
int vx() { return x1 - x2; }
int vy() { return y1 - y2; }
};
bool isParallel(Line& a, Line& b){
return a.vx() * b.vy() == b.vx() * a.vy();
}
bool isVertical(Line& a, Line& b){
return a.vx() * b.vx() + a.vy() * b.vy() == 0;
}
bool isSame(Line& a, Line& b){
// Line c(a.x1, a.y1, b.x1, b.y1);
// return isParallel(a, c);
return (a.x1 == b.x1 && a.y1 == b.y1) && (a.x2 == b.x2 && a.y2 == b.y2) ||
(a.x1 == b.x2 && a.y1 == b.y2) && (a.x2 == b.x1 && a.y2 == b.y1);
}
bool judge(vector<Line>& vec){
int p = 0, v = 0;
for(int i = 0; i < 4; ++i){
for(int j = 0; j < 4; ++j){
if(i == j) continue;
if(isParallel(vec[i], vec[j]) && !isSame(vec[i], vec[j])) p++;
if(isVertical(vec[i], vec[j])) v++;
}
}
return p == 4 && v == 8;
}
int main(){
#ifdef EXMY
freopen("data.in", "r", stdin);
#endif // EXMY
int n;
cin >> n;
while(n--){
vector<Line> vec;
for(int i = 0; i < 4; ++i){
int x1, y1, x2, y2; cin >> x1 >> y1 >> x2 >> y2;
vec.push_back(Line(x1, y1, x2, y2));
}
if(judge(vec)) cout << "YES" << endl;
else cout << "NO" << endl;
}
return 0;
}