HDU - 1069 Monkey and Banana (dp)

传送门

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food. 

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks. 
Input
The input file will contain one or more test cases. The first line of each test case contains an integer n, 
representing the number of different blocks in the following data set. The maximum value for n is 30. 
Each of the next n lines contains three integers representing the values xi, yi and zi. 
Input is terminated by a value of zero (0) for n. 
Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height". 
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342
题意:给定一些长方体的长宽高,每一个长方体有无数个且可以任意摆放,现在把这些长方体竖着堆起来,下面一个长方体的长和宽要严格大于上面长方体的宽和高,问堆起来的最大高度是多少?

解法:普通dp,虽然说每一个长发体有无数个,但其实能用的只有三种状况,即长方体的长宽高以不同的方式摆放,然后就是简单的dp了。

#include<stdio.h>
#include<set>
#include<algorithm>
#include<queue>
#include<math.h>
#include<string>
#include<string.h>
#include<iostream>
using namespace std;
typedef long long ll;

struct node{
    int x , y , z;
}no[100];
int dp[100];
bool cmp(node x , node y){
    return x.x < y.x ;
}
int main()
{
    int n;
    int kk = 1;
    while(~scanf("%d" , &n) && n){
        int k = 0;
        int x , y , z ;
        for(int i = 0 ; i < n ; i ++){
            scanf("%d%d%d" , &x , &y , &z);
            no[k].x = min(x , y) ; no[k].y = max(x , y) ; no[k].z = z;
            k++;
            no[k].x = min(x , z) ; no[k].y = max(x , z) ; no[k].z = y;
            k++;
            no[k].x = min(y , z) ; no[k].y = max(y , z) ; no[k].z = x;
            k++;
        }
        sort(no , no + k , cmp);
        int maxn = 0;
        for(int i = 0 ; i < k ; i ++){
            dp[i] = no[i].z ;
            for(int j = 0 ; j < i ; j ++){
                if(no[i].y > no[j].y && no[i].x > no[j].x){
                    dp[i] = max(dp[i] , dp[j] + no[i].z);
                }
            }
            maxn = max(maxn , dp[i]);
        }
        printf("Case %d: maximum height = " , kk ++);
        cout<<maxn<<endl;
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值