hdu3631(floyd入门)

99 篇文章 2 订阅

    今天刚学了图论的几个算法,在hdu上找了几道题练练手,这道题没啥难度,就是输出格式比较坑,WA了半小时.....注意空行那里的处理,太坑爹了!


Shortest Path

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5319    Accepted Submission(s): 1287


Problem Description
When YY was a boy and LMY was a girl, they trained for NOI (National Olympiad in Informatics) in GD team. One day, GD team’s coach, Prof. GUO asked them to solve the following shortest-path problem.
There is a weighted directed multigraph G. And there are following two operations for the weighted directed multigraph:
(1) Mark a vertex in the graph.
(2) Find the shortest-path between two vertices only through marked vertices.
For it was the first time that LMY faced such a problem, she was very nervous. At this moment, YY decided to help LMY to analyze the shortest-path problem. With the help of YY, LMY solved the problem at once, admiring YY very much. Since then, when LMY meets problems, she always calls YY to analyze the problems for her. Of course, YY is very glad to help LMY. Finally, it is known to us all, YY and LMY become programming lovers.
Could you also solve the shortest-path problem?
 

Input
The input consists of multiple test cases. For each test case, the first line contains three integers N, M and Q, where N is the number of vertices in the given graph, N≤300; M is the number of arcs, M≤100000; and Q is the number of operations, Q ≤100000. All vertices are number as 0, 1, 2, … , N - 1, respectively. Initially all vertices are unmarked. Each of the next M lines describes an arc by three integers (x, y, c): initial vertex (x), terminal vertex (y), and the weight of the arc (c). (c > 0) Then each of the next Q lines describes an operation, where operation “0 x” represents that vertex x is marked, and operation “1 x y” finds the length of shortest-path between x and y only through marked vertices. There is a blank line between two consecutive test cases.
End of input is indicated by a line containing N = M = Q = 0.
 

Output
Start each test case with "Case #:" on a single line, where # is the case number starting from 1.
For operation “0 x”, if vertex x has been marked, output “ERROR! At point x”.
For operation “1 x y”, if vertex x or vertex y isn’t marked, output “ERROR! At path x to y”; if y isn’t reachable from x through marked vertices, output “No such path”; otherwise output the length of the shortest-path. The format is showed as sample output.
There is a blank line between two consecutive test cases.
 

Sample Input
 
     
5 10 10 1 2 6335 0 4 5725 3 3 6963 4 0 8146 1 2 9962 1 0 1943 2 1 2392 4 2 154 2 2 7422 1 3 9896 0 1 0 3 0 2 0 4 0 4 0 1 1 3 3 1 1 1 0 3 0 4 0 0 0
 

Sample Output
 
     
Case 1: ERROR! At point 4 ERROR! At point 1 0 0 ERROR! At point 3 ERROR! At point 4
 

Source


floyd模板  然后一个一个插进去。。

#include <bits/stdc++.h>  
#define inf 99999999  
using namespace std;  
int mp[350][350];  
int vis[350];  
int n,m,q;  
void floyd(int k)  
{  
    int i,j;  
    for(i=0;i<n;i++)  
    {  
        for(j=0;j<n;j++)  
        {  
            if(mp[i][j]>mp[i][k]+mp[k][j])  
                mp[i][j]=mp[i][k]+mp[k][j];  
        }  
    }  
}  
int main()  
{  

    int kcase=1;  
    while(scanf("%d%d%d",&n,&m,&q)&&n+m+q)  
    {    
        int i,j;  
        memset(vis,0,sizeof(vis));  
        for(i=0;i<=n;i++)  
            for(j=0;j<=n;j++)  
                mp[i][j]=(i==j?0:inf);  
        for(i=0;i<m;i++)  
        {  
            int a,b,c;  
            scanf("%d%d%d",&a,&b,&c);  
            if(c<mp[a][b])  
                mp[a][b]=c;  
        }  
        if(kcase!=1)  
            cout<<endl;
        printf("Case %d:\n",kcase++);  
        for(i=0;i<q;i++)  
        {  
            int flag;  
            scanf("%d",&flag);  
            if(flag==0)  
            {  
                int u;  
                scanf("%d",&u);  
                if(vis[u]==1)  
                    printf("ERROR! At point %d\n",u);  
                else  
                {  
                    vis[u]=1;  
                    floyd(u);  
                }  
            }  
            else  
            {  
                int s,d;  
                scanf("%d%d",&s,&d);  
                if(vis[s]==0||vis[d]==0)  
                    printf("ERROR! At path %d to %d\n",s,d);  
                else if(mp[s][d]>=inf)  
                    printf("No such path\n");  
                else  
                    printf("%d\n",mp[s][d]);  
            }  
        }  
    }  
    return 0;  
}  


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值