hdu5776 sum

sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 588    Accepted Submission(s): 286


Problem Description
Given a sequence, you're asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO
 

Input
The first line of the input has an integer T ( 1T10 ), which represents the number of test cases. 
For each test case, there are two lines:
1.The first line contains two positive integers n, m ( 1n100000 1m5000 ).
2.The second line contains n positive integers x ( 1x100 ) according to the sequence.
 

Output
Output T lines, each line print a YES or NO.
 

Sample Input
  
  
2 3 3 1 2 3 5 7 6 6 6 6 6
 

Sample Output
  
  
YES NO
 


若 x % m = b 且 y % m = b,那么x可以写成x = a1 * m + b,y可以写成y = a2 * m + b,(y - x) % m = ((a2 - a1) * m) % m = 0

可以用一个前缀和记录x和y,若出现x % m == y % m,那么x到y这一段的子列和就是m的倍数,由于x % m 在[0, m - 1]之间,

再根据鸽笼原理可知,出现模m后相等的情况不会超过m次求和判断,可求


#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <map>

using namespace std;

int T, n, m, cur, sum;
map<int, int> mp;

int main()
{
	cin >> T;
	while (T--) {
		mp.clear();
		scanf("%d%d", &n, &m);
		sum = 0;
		bool flag = false;
		for (int i = 0; i < n; i++) {
			scanf("%d", &cur);
			sum = (sum + cur) % m;
			if (sum == 0) {
				flag = true;
			}
			if (mp[sum] == 0) {
				mp[sum] = 1;
			}
			else {
				flag = true;
			}
		}
		puts(flag ? "YES" : "NO");
	}
	return 0;
}







  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值