ACM竞赛学习记录------River Hopscotch(二分搜索)

题目链接:https://vjudge.net/problem/POJ-3258
题目:

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input
Line 1: Three space-separated integers: L, N, and M
Lines 2… N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.
Output
Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks
Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint
Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

题目大意:一条河流上有N块石头,可以移走M块石头,该移走哪几颗石头才能使所有石块间隔最小的最大?

解题思路:使用二分法对最小间隔进行枚举,用一个整型变量move来记录要达成该枚举的最小间隔至少要移除多少块石头,若move>M,则说明枚举的间隔比正确答案大,应该使用二分法在move左侧继续枚举;若move<=M
则说明正确答案在move上或者是move的右侧,应使用二分法在move右侧继续枚举,最后便可获得正确答案。

AC代码:

#include <cstdlib>
#include <iostream>
#include <stdlib.h>     /* qsort */
#include <algorithm>
using namespace std;
/*
25 5 2
2
14
11
21
17
*/
int K, N, L;
int D[50010];
bool judge(int d) {
	int move = 0;
	int start = 0;
	for (int i = 1; i <= N+1; i++)
	{
		if (D[i]-D[start]<d)
		{
			move++;
		}
		else
		{
			start = i;
		}
	}
	//移动的石头是否多出?
	if (move>K)
	{
		return false;
	}
	else
	{
		return true;
	}

}
int main()
{
	cin >>L>> N>> K;
	for (int i = 1; i <= N; i++)
	{
		cin >> D[i];
	}
	//左右顶点
	D[0] = 0;
	D[N+1] = L;
	sort(D, D+N+2);
	int left = 0, right = L+1,middle;
	while (right-left>1)
	{
		middle = (right + left) / 2;
		if (judge(middle))
		{
			left = middle;
		}
		else
		{
			//保证不在右端点
			right = middle;
		}
	}
	cout << left;
	
}/*#1
10 1 1
6

#2
10 0 0
*/
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值