hdu 2421

43 篇文章 0 订阅

点击打开题目链接

Deciphering Password

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1550    Accepted Submission(s): 374


Problem Description
Xiaoming has just come up with a new way for encryption, by calculating the key from a publicly viewable number in the following way:
Let the public key N = A B, where 1 <= A, B <= 1000000, and a 0, a 1, a 2, …, a k-1 be the factors of N, then the private key M is calculated by summing the cube of number of factors of all ais. For example, if A is 2 and B is 3, then N = A B = 8, a 0 = 1, a 1 = 2, a 2 = 4, a 3 = 8, so the value of M is 1 + 8 + 27 + 64 = 100.
However, contrary to what Xiaoming believes, this encryption scheme is extremely vulnerable. Can you write a program to prove it?
 

Input
There are multiple test cases in the input file. Each test case starts with two integers A, and B. (1 <= A, B <= 1000000). Input ends with End-of-File.
Note: There are about 50000 test cases in the input file. Please optimize your algorithm to ensure that it can finish within the given time limit.
 

Output
For each test case, output the value of M (mod 10007) in the format as indicated in the sample output.
 

Sample Input
  
  
2 2 1 1 4 7
 

Sample Output
  
  
Case 1: 36 Case 2: 1 Case 3: 4393
 

Source

代码:

#include<stdio.h>
#include<iostream>
#include<cstring>
#define MAXN 1010
using namespace std;
int prim[MAXN],p[200];
void init()
 {

    int i, j, k = 0;
    memset(prim,1,sizeof(prim));
    for(i=2;i<35;++i)
    {
        if(prim[i])
            for(j=i;j*i<MAXN;++j)
                prim[i*j]=0;
    }
    for(i=2;i<MAXN;++i)
        if(prim[i])
            p[k++] = i;

 }
 int main()
 {
     int m,n,sum=1,ans,t=1,tmp,i,j;
     init();
    while(~scanf("%d%d",&m,&n))
     {
        sum=1;
      for(i=0;i<169;i++)
       {
            tmp=0;
         while(m%p[i]==0&&m!=1)
           {
               m/=p[i];
               tmp++;
           }
         tmp=(tmp*n%10007+1)%10007;
         tmp=tmp*(tmp+1)/2%10007;
         sum=sum*(tmp*tmp%10007)%10007;
        if(m==1) break;
       }
       if(m!=1)
         {
             tmp=(n+1)%10007;
             tmp=tmp*(tmp+1)/2%10007;
             sum=sum*(tmp*tmp%10007)%10007;
         }

      printf("Case %d: %d\n",t++,sum);
     }

     return 0;
 }






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值