Description
今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑
每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的
考生,并将他们的成绩按降序打印。
每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的
考生,并将他们的成绩按降序打印。
Input
测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N
< 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至
< 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至
第M题的正整数分值;以下N行,每行给出一
名考生的准考证号(长度不超过20的
字符串)、该生解决的题目总数m、以及这m道题的题号
(题目号由1到M)。
当读入的考生人数为0时,输入结束,该场考试不予处理。
Output
对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高
到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考
号的升序输出。
到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考
号的升序输出。
Sample Input
4 5 25 10 10 12 13 15 CS004 3 5 1 3 CS003 5 2 4 1 3 5 CS002 2 1 2 CS001 3 2 3 5 1 2 40 10 30 CS001 1 2 2 3 20 10 10 10 CS000000000000000001 0 CS000000000000000002 2 1 2 0
Sample Output
3 CS003 60 CS001 37 CS004 37 0 1 CS000000000000000002 20
Hint
Huge input, scanf is recommended.
样例:
#include <stdio.h>
#include <string.h>
int N;
struct Student //定义考生信息结构体
{
char id[100]; //考号
int num; //完成题目的个数
int score; //总分
};
int compare(struct Student a,struct Student b) //定义比较函数
{
int book=0;
if(a.score<b.score) //1.总分排序
book=1;
else if(a.score==b.score)
{
if(strcmp(a.id,b.id)>=0) //2.学号排序
book=1;
}
return book;
}
void sort(struct Student a[],int left,int right) //快排
{
int i,j,x;
struct Student step,m;
i=left,j=right,step=a[left];
if(i>j)
return;
while(i!=j)
{
while(i<j&&compare(a[j],step))
j--;
while(i<j&&compare(step,a[i]))
i++;
if(i<j)
m=a[i],a[i]=a[j],a[j]=m;
}
a[left]=a[i],a[i]=step;
sort(a,left,i-1);
sort(a,i+1,right);
}
int main()
{
struct Student student[1200];
int i,j,m,n,step,sum,p,times;
int _score[100]; //定义结构体数组用于存放考生信息
while(scanf("%d",&m)&&m)
{
scanf("%d%d",&n,&step); //输入题目数量、录取分
for(i=0;i<n;i++)
scanf("%d",&_score[i]); //输入每个题目分值
for(i=0;i<m;i++) //循环m次输入考生信息
{
scanf("%s%d",student[i].id,&student[i].num);
sum=0;
for(j=0;j<student[i].num;j++)
{
scanf("%d",&p);
sum+=_score[p-1]; //累加考生得分
}
student[i].score=sum; //赋值考生总分
}
times=0;
for(i=0;i<m;i++)
{
if(student[i].score>=step)
times++; //计数通过录取分的考试人数
}
sort(student,0,m-1); //排序
printf("%d\n",times); //输出
for(i=0;i<times;i++)
printf("%s %d\n",student[i].id,student[i].score);
}
return 0;
}
这道题一个坑人点,当总分一样的时候要按照学号升序排列,其他地方主要就是对信息的存放排序处理