H - Big Event in HDU

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input

2

10 1

20 1

3

10 1

20 2

30 1

-1

Sample Output

20 10

40 40

  • 题意概括  :

杭电的计算机学院,被分成两个学院,分裂意味着所有设施必须减半,首先对所有设施进行评估,如果两个设施价值相同,他们被认为相同,有n种设施,不同值不同种类,每种设施有对应的数目,,现在将所有设施分成两份,A和B分别表示计算机学院和软件学院的价值,要求,A和B尽可能相等,同时A不小于B,输入-1时表示结束本行不做处理。

  • 解题思路  :

首先,将所有设施的价值全都加起来,然后将所有设施的数目也都加起来,用i控制设施数目,j控制设施价值,从设施的价值的一半开始。状态转移方程 :dp[j] = max(dp[j],dp[j-v[i]]+v[i]);最后输出sum-dp【sum/2】和dp【sum/2】。

#include<stdio.h>
#include<string.h>
#include<algorithm>

using namespace std;

int v[5005],dp[255555];
int n,sum,num;

int DP()
{
    int i,j,k;

    for(i = 0;i<num;i ++)
    {
        for(j = sum/2;j>=v[i];j --)
        {
            dp[j] = max(dp[j],dp[j-v[i]]+v[i]);
        }
    }
    printf("%d %d\n",sum-dp[sum/2],dp[sum/2]);
}
int main()
{
    int i,j,a,b;
    
    while(~ scanf("%d",&n))
    {
        memset(dp,0,sizeof(dp));
        memset(v,0,sizeof(v));
        if(n < -1)
        break;
        sum = 0;
        num = 0;
        for(i = 1;i<=n;i ++)
        {
            scanf("%d %d",&a,&b);
            while(b --)
            {
                v[num ++] = a;
                sum += a;
            }
        }
        DP();
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值