G - Cat VS Dog(二分匹配 匈牙利)

The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child's like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child's like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.

Input

The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child's like-animal and dislike-animal, C for cat and D for dog. (See sample for details)

Output

For each case, output a single integer: the maximum number of happy children.

Sample Input

1 1 2

C1 D1

D1 C1

 

1 2 4

C1 D1

C1 D1

C1 D2

D2 C1

Sample Output

1

3

 

 

        

  

Hint

Case 2: Remove D1 and D2, that makes child 1, 2, 3 happy.

  • 题意概括  :

动物园有n个猫和m条狗,然后给出p行,每行包含一个孩子喜欢动物和不喜欢动物,如果一个孩子不喜欢的是猫,那么他喜欢的一定是狗,反之一样。如果一个孩子喜欢的动物被删除,那么这个孩子就会不高兴,不喜欢的动物被删除则会很高兴,问快乐儿童的最大数量。

  • 解题思路  :

首先,判断两个动物是否矛盾,然后建图,匈牙利算法,求出最大匹配数,因为这个图是重复的,所以求出的最大匹配数除以二,才是实际的最大匹配数,然后用关系数减去最大匹配数,即为快乐儿童的最大匹配数。

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

int n,m,p;
char a[1005][12],b[1005][12];
int map[1005][520],book[1005],girl[1005];

int dfs(int u)
{
	int i;
	
	for(i = 0;i<p;i ++)
	{
		if(book[i] == 0&&map[u][i] == 1)
		{
			book[i] = 1;
			
			if(girl[i] == 0||dfs(girl[i]))
			{
				girl[i] = u;
				
				return 1;
			}
		}
	}
	return 0;
}

int main()
{
	int i,j,sum;
	
	while(~ scanf("%d %d %d",&n,&m,&p))
	{
		sum = 0;
		memset(girl,0,sizeof(girl));
		memset(map,0,sizeof(map));
		
		for(i = 0;i<p;i ++)
		{
			scanf("%s %s",a[i],b[i]);
		}
		
		for(i = 0;i<p;i ++)
		{
			for(j = i+1;j<p;j ++)
			{
				if(strcmp(a[i],b[j]) == 0||strcmp(a[j],b[i]) == 0)
				{
					map[i][j] = 1;
					map[j][i] = 1;
				}
			}
		}
		for(i = 0;i<p;i ++)
		{
			memset(book,0,sizeof(book));
			
			if(dfs(i))
			sum ++;
		}
		printf("%d\n",p-sum/2);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值