poj1945 Power Hungry Cows BFS

Description
FJ’s cows would like to be able to compute integer powers P (1 <= P <= 20,000) of numbers very quickly, but need your help. Because they’re going to be computing powers of very large numbers, they can only keep around two work variables for intermediate results.

The first of those work variables is initialized to the number (denoted x) for which they are calculating the power; the other is initialized to 1. The cows can both multiply and divide any pair of the work variables and store the result in any work variable, but all results are stored as integers.

For example, if they want to compute x^31, one way to perform the calculation is:

                                          WV1  WV2

                                  Start:   x    1

Multiply first by first, store in second: x x^2

              Multiply second by second:   x   x^4

              Multiply second by second:   x   x^8

              Multiply second by second:   x   x^16

              Multiply second by second:   x   x^32

                 Divide second by first:   x   x^31

Thus, x^31 can computed in six operations. Given the power to be computed and the the number of work variables, find the minimum number of operations to calculate the power.

Input
A single line with one integer: P.

Output
A single line with a single integer that is the minimum number of operations it requires to compute the power.

Sample Input
31

Sample Output
6

题目大意
从数对(0, 1)开始,每次可以把两个数(可以取同一个数两次)相加或相减并替换原来的任意一个数,问得到给定的n的最少操作步数。

输入
一个整数n

输出
一个整数代表最少操作步数

这道题网上可以用A*启发式搜索做,但是我用的BFS。一开始犯了两个及其弱智的错误
1.pd函数未return
2.w=to.z忘记加1

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<string>
#include<vector>
#include<stack>
#include<set>
#include<queue>
using namespace std;
const int p1=20101,p2=97;
int n,m,ans;
struct node{
    int x,y,z;
};
queue <node> q;
bool hash[p1][p2];
node make(int x,int y,int z){
    node u;
    u.x=x;
    u.y=y;
    u.z=z;
    return u;
}
bool pd(int u,int v,int w){
    int i,j,k;
    if (u==n || v==n)
        return true;
    if (u<v) swap(u,v);
    if (u==v || u>=m || v>=p2)
        return false;
    if (!hash[u][v]){
        hash[u][v]=true;
        q.push(make(u,v,w));
    }
    return false;
}
int main(){
    scanf("%d",&n);
    m=n+p2;
    pd(1,0,0);
    while(!q.empty()){
        node to=q.front();
        q.pop();
        int u=to.x,v=to.y,w=to.z+1;
        if(pd(u+u,v,w) || pd(u+v,v,w) || pd(u+v,v,w) || pd(u,u+u,w) || pd(u,u+v,w) || pd(u,v+v,w) || pd(u,u-v,w) || pd(u-v,u,w)){
            ans=w;
            break;
        }
    }
    printf("%d\n",ans);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值