POJ 1704 Georgia and Bob(尼姆博弈)

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example: 

Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game. 

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out. 

Given the initial positions of the n chessmen, can you predict who will finally win the game? 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win


题目大意:

    给一个1*M的棋盘,上面有N颗棋子,每人每次只能向左移动一颗棋子,并且至少移动一步,两人轮流操作,如果某人不能移动棋子了,那他就输了。

解题思路:

    将棋子分成两两一组,如果棋子数是奇数,前面补0。如果先手移动的是一组当中左边的棋子,那么后手只要将该组右边的棋子移动相同的步数,就行了;如果先手移动的是右边的棋子,将两颗棋子之间的距离看作是石子的数目,只需按照取石子的操作即可。本题是尼姆博弈类型,有N堆石子,两人轮流取,每人每次至少取一个,最后取完石子的人赢。

     将棋子分组后,两两棋子之间的距离为L1,L2,L3,……,Ln,则L1^L2^L3^……^Ln=0时,Bob赢,否则,Georgia赢

代码如下:

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
	int i,j,t,N,T,P[1005];
    scanf("%d",&T);
    while (T--)
    {
		scanf("%d",&N);
		for(i=1;i<=N;i++)
			scanf("%d",&P[i]);
		sort(P+1,P+1+N);//从小到大排序
		t=0;
		j=1;
		if(N%2==1)//N是奇数时
		{
			t=P[1]-1;
			j++;
		}
		for(i=j;i<=N;i+=2)
		{
			t^=P[i+1]-P[i]-1;
		}
		if(t==0)
			puts("Bob will win");
		else
			puts("Georgia will win");
    }
    return 0;
}







  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值