Cube Stacking 1988 (并查集 好题)

Cube Stacking
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 21402 Accepted: 7492
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2
//好题::运用并查集
/*题意::
有N个立方体(筛子),从1到N编号,现在用这些立方体(筛子)做一个游戏 
输入一个t,表示有几行,再输入一个字符,若字符是‘M’,则输入两个数,表示两个筛子的编号x,y,表示将
x放到y上面 ,若字符为‘C’,则输入一个数,表筛子编号,然后输出这个筛子下面有几个筛子。*/

//例如::输入样例(这块看了半天没看懂) 
/*   M  1  6  表示将1放到6上面
		
		1
		6
	
	C   1   表示输出1下面有几个数,很容易看出有一个
	M   2  4  表示将2放到4上
	
		2
		4

	M   2  6  ***这块重点,表示将2放到6上
	
		2     他每次输入都是连续的,即使有输出也不会中断,直到输入的行数等于 t 。
		4    
		1
		6
		
	C   4  表示4下面有几个数,可以看出有2个。*/	 
//集体解题思路见代码 
<pre class="cpp" name="code">#include<stdio.h>
#include<string.h>
#include<math.h>
int a[30110];
int b[30110];//记录从该节点到最后节点的深度 
int s[30110];//记录节点所处的深度 
int find(int x)
{
	if(x!=a[x])
	{
		int t=a[x];
		a[x]=find(a[x]);
		s[x]+=s[t];
	}
	return a[x];
}
int marge(int x,int y)
{
	int fx,fy;
	fx=find(x);
	fy=find(y);
	if(fx!=fy)
	{
		a[fy]=fx;
		s[fy]=b[fx];//这块是重点,自己多找几个点模拟一下就清楚了 
		b[fx]+=b[fy];
	}
}
int main(){
	int t;
	while(scanf("%d",&t)!=EOF)
	{
		int i,x,y;
		char c;
		for(i=0;i<=30000;i++)
		{
			a[i]=i;
			b[i]=1;
			s[i]=0;
		}
		while(t--)
		{
			getchar();
			scanf("%c",&c);
			if(c=='M')
			{
				scanf("%d%d",&x,&y);
				marge(x,y);
			}
			else 
			{
				scanf("%d",&x);
				int dx=find(x);//找到根节点 
				printf("%d\n",b[dx]-s[x]-1);//从根节点到要找的节点间的节点数
			}
		}
	}
	return 0;
}


                
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值