poj Balanced Lineup (线段树区间最值+优化)

Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 40872 Accepted: 19220
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0
//这个题和nyoj上的‘士兵杀敌(三)’一样,但时间上比nyoj卡的死,所以超时了几次。。。加个优化就过了。
//具体看代码
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 50010
#define INF 0x3f3f3f
using namespace std;
int a[N];
int mma,mmi;
struct zz
{
	int l;
	int r;
	int ma;
	int mi;
}q[4*N];
void build(int gen,int l,int r)
{
	q[gen].l=l;
	q[gen].r=r;
	if(l==r)
	{
		q[gen].ma=q[gen].mi=a[l];
		return ;
	}
	int mid=(l+r)/2;
	build(gen<<1,l,mid);
	build(gen<<1|1,mid+1,r);
	q[gen].ma=max(q[gen<<1].ma,q[gen<<1|1].ma);
	q[gen].mi=min(q[gen<<1].mi,q[gen<<1|1].mi);
}
void query(int gen,int l,int r)
{
	if(q[gen].ma<=mma&&q[gen].mi>=mmi)//关键,不优化就超时 
		return ;
	if(q[gen].l==q[gen].r)
	{
		mma=max(mma,q[gen].ma);
		mmi=min(mmi,q[gen].mi);
		return ;
	}
	int mid=(q[gen].l+q[gen].r)/2;
	if(r<=mid)
		query(gen<<1,l,r);
	else if(l>mid)
		query(gen<<1|1,l,r);
	else
	{
		query(gen<<1,l,mid);
		query(gen<<1|1,mid+1,r);
	}
}
int main()
{
	int n,m;
	int i;
	int x,y;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		build(1,1,n);
		while(m--)
		{
			scanf("%d%d",&x,&y);
			mma=0;
			mmi=INF;
			query(1,x,y);
			printf("%d\n",mma-mmi);
		}
	}
	return 0;
}

//下面的这个代码运行时间比上面的短四分之一。但表示我还没理解。。。
#include<stdio.h>
#include<string.h>
#include<math.h>
#define MAX(a,b) (a>b?a:b)
#define MIN(a,b) (a>b?b:a)
int a[100010][20];
int b[100010][20];
void RMQ(int n)
{
	int i,j;
	for(j=1;j<20;j++)
	{
		for(i=1;i<=n;i++)
		{
			if(i+(1<<j)-1<=n)
			{
				a[i][j]=MAX(a[i][j-1],a[i+(1<<(j-1))][j-1]);
				b[i][j]=MIN(b[i][j-1],b[i+(1<<(j-1))][j-1]);
			}
		}
	}
}
int main()
{
	int n,m,i,j,x,y;
	scanf("%d%d",&n,&m);
	for(i=1;i<=n;i++)
	{
		scanf("%d",&a[i][0]);
		b[i][0]=a[i][0];
	}
	RMQ(n);
	while(m--)
	{
		scanf("%d%d",&x,&y);
		int s=(int)(log(y-x+1)/log(2));
		int ma=MAX(a[x][s],a[y-(1<<s)+1][s]);
		int mi=MIN(b[x][s],b[y-(1<<s)+1][s]);
		printf("%d\n",ma-mi);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值