hdoj Stars 1541 (树状数组模板&&线段树)

21 篇文章 0 订阅
4 篇文章 0 订阅

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6683    Accepted Submission(s): 2665


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input
  
  
5 1 1 5 1 7 1 3 3 5 5

Sample Output
  
  
1 2 1 1 0
//题意:
有n个点(星星),给你这n个点的二维坐标,然你找出这n个点的左下方有几个点,将它们统计出来,然后再逐个输出左下方有0 , 1 ,2,3,.....n个点的点有几个。
(比较绕口,细细理解)。
//第一次接触树状数组,好简洁。
#include<stdio.h>
#include<string.h>
#define N 32010
int a[N];
int sum[N];
int lowbit(int x)
{
	return x&(-x);
}
int num(int x)
{
	int s=0;
	while(x>0)
	{
		s+=sum[x];
		x-=lowbit(x);
	}
	return s;
}
void update(int x)
{
	while(x<=32000)
	{
		sum[x]++;
		x+=lowbit(x);
	}
}
int main()
{
	int n,i,j;
	int x,y;
	while(scanf("%d",&n)!=EOF)
	{
		memset(a,0,sizeof(a));
		memset(sum,0,sizeof(sum));
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&x,&y);
			a[num(x+1)]++;
			update(x+1);
		}
		for(i=0;i<n;i++)
			printf("%d\n",a[i]);
	}
	return 0;
}

//线段树
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 32010
using namespace std;
int a[N];
int cnt;
struct zz
{
	int l;
	int r;
	int sum;
}q[N<<2];
void build(int gen,int l,int r)
{
	q[gen].l=l;
	q[gen].r=r;
	q[gen].sum=0;
	if(l==r)
		return ;
	int mid=(l+r)/2;
	build(gen<<1,l,mid);
	build(gen<<1|1,mid+1,r);
}
void update(int gen,int l,int r)
{
	if(q[gen].l==r&&q[gen].r==r)
	{
		q[gen].sum++;
		return ;
	}
	int mid=(q[gen].l+q[gen].r)/2;
	if(mid>=r)
		update(gen<<1,l,r);
	else
		update(gen<<1|1,l,r);
	q[gen].sum=q[gen<<1].sum+q[gen<<1|1].sum;
}
void query(int gen,int l,int r)
{
	if(q[gen].l>=l&&q[gen].r<=r)
	{
		cnt+=q[gen].sum;
		return ;
	}
	int mid=(q[gen].l+q[gen].r)/2;
	if(l<=mid)
		query(gen<<1,l,r);
	if(r>mid)
		query(gen<<1|1,l,r);
}
int main()
{
	int n;
	int x,y;
	while(scanf("%d",&n)!=EOF)
	{
		build(1,1,N-1);
		memset(a,0,sizeof(a));
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&x,&y);
			x++;
			cnt=0;
			query(1,1,x);
			a[cnt]++;
			update(1,1,x);
		}
		for(int i=0;i<n;i++)
			printf("%d\n",a[i]);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值