poj Sum of Consecutive Prime Numbers 2739 (素数打表)

40 篇文章 1 订阅
22 篇文章 0 订阅
Sum of Consecutive Prime Numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21392 Accepted: 11719

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20.
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2
//题意:
给你一个数n,让你找出有多少种  一个或多个连续的素数和等于n。

//思路:

//先用素数打表打出0--10000之间的所有素数并将他们逐个储存在p数组中
//sum记录连续素数的和,cnt记录有几种情况。
//然后再将连续的素数相加得sum
//当 sum<n时就继续加上后面的素数
//当sum==n时 cnt++,然后再继续相加,此时sum>n
//当sum> n时,sum就减去刚开始加的小的素数
//这样一直计算下去直到结束,这样就找出了所有连续素数和==n的个数了

#include<stdio.h>
#include<string.h>
#define N 10010
int p[N];
bool pp[N];
int pnum;
void getp()//素数打表,找出所有素数。 
{
	int i,j;
	memset(pp,false,sizeof(pp));
	pnum=0;
	for(i=2;i<=N;i++)
	{
		if(!pp[i])
			p[pnum++]=i;
		for(j=0;j<pnum&&p[j]*i<=N;j++)
		{
			pp[p[j]*i]=1;
			if(i%p[j]==0)
				break;
		}
	}
	pp[0]=1;
	pp[1]=1;
}
int main()
{
	int i,j,n,cnt,sum;
	getp();
	while(scanf("%d",&n),n)
	{
		cnt=sum=0;
		for(i=0,j=0;i<pnum;)
		{
			if(sum<n)
				sum+=p[i++];
			else if(sum==n)
			{
				cnt++;
				sum+=p[i++];
			}
			else
				sum-=p[j++];
		}
		printf("%d\n",cnt);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值