HDU - 4002 Find the maximum (Java大数打表)

40 篇文章 1 订阅
16 篇文章 0 订阅
HDU - 4002
Time Limit: 1000MS Memory Limit: 65768KB 64bit IO Format: %I64d & %I64u

Status

Description

Euler's Totient function, φ (n) [sometimes called the phi function], is used to determine the number of numbers less than n which are relatively prime to n . For example, as 1, 2, 4, 5, 7, and 8, are all less than nine and relatively prime to nine, φ(9)=6.
HG is the master of X Y. One day HG wants to teachers XY something about Euler's Totient function by a mathematic game. That is HG gives a positive integer N and XY tells his master the value of 2<=n<=N for which φ(n) is a maximum. Soon HG finds that this seems a little easy for XY who is a primer of Lupus, because XY gives the right answer very fast by a small program. So HG makes some changes. For this time XY will tells him the value of 2<=n<=N for which n/φ(n) is a maximum. This time XY meets some difficult because he has no enough knowledge to solve this problem. Now he needs your help.

Input

There are T test cases (1<=T<=50000). For each test case, standard input contains a line with 2 ≤ n ≤ 10^100.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

    
    
2 10 100

Sample Output

    
    
6 30

Hint

If the maximum is achieved more than once, we might pick the smallest such n. 
         

Source

The 36th ACM/ICPC Asia Regional Dalian Site —— Online Contest
//题意: 规定fai(n)的值为比n小且与n互质的数的个数
给你一个数n,x是区间[1,n]中的任意一个数,找出最大的x/fai(x)的x。
//思路:
通过模拟找出规律:a[i]=a[i-1]*p[i-1](p[i]表示素数表),因为数很大所以用Java大数打表即可
import java.math.BigInteger;
import java.util.Scanner;



public class Main {
	static int vis[] = new int[1010];
	static int p[] = new int[1010];
	static BigInteger a[] = new BigInteger[110];
	static void getp()
	{
		for(int i = 0; i < 1010; i++)
			vis[i] = 0;
		vis[1] = 1;
		for(int i = 2; i <= 1000; i++)
		{
			if(vis[i] == 0)
			for(int j = i * i; j <= 1000; j += i)
			{
				vis[j] = 1;
			}
		}
		int tp = 0;
		for(int i = 1; i <= 1000; i++)
		{
			if(vis[i] == 0)
				p[tp++] = i;
		}
	}
	public static void main(String[] args){
		Scanner cin = new Scanner(System.in);
		getp();
		a[0]=BigInteger.valueOf(1);
		for(int i=1;i<=100;i++)
		{
			a[i] = a[i-1].multiply(BigInteger.valueOf(p[i-1]));
		}
		int t = cin.nextInt();
		while(t-- > 0)
		{
			BigInteger x;
			x = cin.nextBigInteger();
			if(x.compareTo(BigInteger.valueOf(6)) < 0){
				System.out.println("2");
				continue;
			}
			for(int i=0;i<=100;i++)
			{
				if(a[i].equals(x)){
					System.out.println(a[i]);
					break;
				}
				else if(a[i].compareTo(x) > 0)
				{
					System.out.println(a[i-1]);
					break;
				}
			}
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值