poj Squares 2002 (STL&&枚举+转换) 统计正方形的个数

99 篇文章 0 订阅
59 篇文章 0 订阅
Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 17886 Accepted: 6845

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1
//题意:
给你n个点,让你求出这n个点能组成几个正方形。
参考博客:http://m.blog.csdn.net/blog/u013480600/39500427
 
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 1010
using namespace std;
struct zz
{
	int x;
	int y;
	friend bool operator<(zz a,zz b)
	{
		return a.x<b.x||(a.x==b.x&&a.y<b.y);
	}
}q[N<<1],tmp;
int main()
{
	int n,i,j,k;
	while(scanf("%d",&n),n)
	{
		for(i=0;i<n;i++)
			scanf("%d%d",&q[i].x,&q[i].y);
		sort(q,q+n);
		int cnt=0;
		for(i=0;i<n;i++)
		{
			for(j=i+1;j<n;j++)
			{
				tmp.x=q[i].x+q[i].y-q[j].y;
				tmp.y=q[i].y+q[j].x-q[i].x;
				if(!binary_search(q,q+n,tmp))
					continue;
				tmp.x=q[j].x+q[i].y-q[j].y;
				tmp.y=q[j].y+q[j].x-q[i].x;
				if(!binary_search(q,q+n,tmp))
					continue;
				cnt++;
			}
		}
		printf("%d\n",cnt/2);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值