hdoj Another Sum Problem 2576 (数学题)

Another Sum Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1480    Accepted Submission(s): 408


Problem Description
FunnyAC likes mathematics very much. He thinks mathematics is very funny and beautiful.When he solved a math problem he would be very happy just like getting accepted in ACM.Recently, he find a very strange problem.Everyone know that the sum of sequence from 1 to n is n*(n + 1)/2. But now if we create a sequence which consists of the sum of sequence from 1 to n. The new sequence is 1, 1+ 2, 1+2+3, .... 1+2+...+n. Now the problem is that what is the sum of the sequence from1 to 1+2+...+n .Is it very simple? I think you can solve it. Good luck!

Input
The first line contain an integer T .Then T cases followed. Each case contain an integer n (1 <= n <= 10000000).

Output
For each case,output the sum of first n items in the new sequence. Because the sum is very larger, so output sum % 20090524.

Sample Input
  
  
3 1 24 56

Sample Output
  
  
1 2600 30856
 
//这个代码一直超时,也想不出其他的代码了,先贴上。
#include<stdio.h>
#include<string.h>
#define mod 20090524
int main()
{
	int t,n,m;
	int i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		m=0;
		for(i=n,j=1;i>=1;i--,j++)
		{
			m=(m+i*j%mod)%mod;
		}
		printf("%d\n",m);
	}
	return 0;
}

//这个是大神写的,还不懂啥意思。
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#define mod 20090524;
using namespace std;
__int64 sum[4][4],array[4][4];
void MatrixMult(__int64 a[4][4],__int64 b[4][4])
{
    __int64 c[4][4]={0};
    for(int i=0;i<4;++i)
	{
        for(int j=0;j<4;++j)
		{
            for(int k=0;k<4;++k)
			{
                c[i][j]+=a[i][k]*b[k][j];
            }
        }
    }
    for(int i=0;i<4;++i)
	{
        for(int j=0;j<4;++j)
			a[i][j]=c[i][j]%mod;
    }
}

__int64 MatrixPow(int k)
{
    for(int i=0;i<4;++i)
	{
        for(int j=0;j<4;++j)
			sum[i][j]=(i == j);
    }
    array[0][0]=array[0][1]=array[0][2]=1,array[0][3]=0;
    array[1][1]=array[1][2]=1,array[1][0]=array[1][3]=0;
    array[2][2]=array[2][3]=1,array[2][0]=array[2][1]=0;
    array[3][3]=1,array[3][0]=array[3][1]=array[3][0]=0;
    while(k)
	{
        if(k&1)
			MatrixMult(sum,array);
        MatrixMult(array,array);
        k>>=1;
    }
    return (sum[0][2]+sum[0][3])%mod;
}

int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
	{
        scanf("%d",&n);
        printf("%I64d\n",MatrixPow(n));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
【1】项目代码完整且功能都验证ok,确保稳定可靠运行后才上传。欢迎下载使用!在使用过程中,如有问题或建议,请及时私信沟通,帮助解答。 【2】项目主要针对各个计算机相关专业,包括计科、信息安全、数据科学与大数据技术、人工智能、通信、物联网等领域的在校学生、专业教师或企业员工使用。 【3】项目具有较高的学习借鉴价值,不仅适用于小白学习入门进阶。也可作为毕设项目、课程设计、大作业、初期项目立项演示等。 【4】如果基础还行,或热爱钻研,可基于此项目进行二次开发,DIY其他不同功能,欢迎交流学习。 【注意】 项目下载解压后,项目名字和项目路径不要用中文,否则可能会出现解析不了的错误,建议解压重命名为英文名字后再运行!有问题私信沟通,祝顺利! 基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值