hdoj Binary Tree 5573 (二叉树+思想)

211 篇文章 1 订阅
85 篇文章 0 订阅

Binary Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 107    Accepted Submission(s): 60
Special Judge


Problem Description
The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.

Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 1 . Say froot=1 .

And for each node u , labels as fu , the left child is fu×2 and right child is fu×2+1 . The king looks at his tree kingdom, and feels satisfied.

Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another N years, only if he could collect exactly N soul gems.

Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node x , the number at the node is fx (remember froot=1 ), he can choose to increase his number of soul gem by fx , or decrease it by fx .

He will walk from the root, visit exactly K nodes (including the root), and do the increasement or decreasement as told. If at last the number is N , then he will succeed.

Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.

Given N , K , help the King find a way to collect exactly N soul gems by visiting exactly K nodes.

Input
First line contains an integer T , which indicates the number of test cases.

Every test case contains two integers N and K , which indicates soul gems the frog king want to collect and number of nodes he can visit.

1T100 .

1N109 .

N2K260 .

Output
For every test case, you should output " Case #x:" first, where x indicates the case number and counts from 1 .

Then K lines follows, each line is formated as 'a b', where a is node label of the node the frog visited, and b is either '+' or '-' which means he increases / decreases his number by a .

It's guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.


Sample Input
  
  
2 5 3 10 4

Sample Output
  
  
Case #1: 1 + 3 - 7 + Case #2: 1 + 3 + 6 - 12 +
 
//题意: 首先,给你一棵完整的二叉树,并且根节点值为1,节点的编号为节点的价值。 有t组输入,每组输入有一个n,一个k。表示从根节点出发沿着树边遍历k个节点 对于每个节点,可以选择加上或减去此节点的值,使得最后得到的值等于n. //思路 由于题目限制N<=2^k,将问题简化,只用最左边的那2*k-1个节点来表示。 先找到一个F=2^(k+1)- 1>=n; 变换可得f=2^(k+1)-1-n;(多余的数)。 1、 然后向上遍历要保证f为奇数,这样才能保证在上面的k+1层内都走最左边。  如果f为偶数,那么先走第(k+1)层的第二个,将f变为奇数,这样就保证了  在上面的k层内都走最左边。 2、向上遍历找到使得(k+1)层的和最终等于f,也就是遍历(k+1)层使得层数和为(f/2)  则标记这几层为‘-’,其他的为‘+’。
 
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define ll long long
using namespace std;
ll a[70];
ll ans[70];
bool mark[70];
void getf()
{
	int i;
	a[0]=1;
	for(i=1;i<=61;i++)
		a[i]=a[i-1]*2;
}
int main()
{
	getf();
	int t,T=1;
	int i,j;
	scanf("%d",&t);
	while(t--)
	{
		int k;
		ll n;
		scanf("%lld",&n);
		scanf("%d",&k);
		for(i=0;i<k;i++)
			ans[i]=a[i];
		ll dis=a[k]-1-n;
		if(n%2==0)
		{
			ans[k-1]++;
			dis++;
		}
		dis/=2;
		int kk=0;
		memset(mark,false,sizeof(mark));
		while(dis)
		{
			if(dis&1ll)
				mark[kk]=true;
			kk++;
			dis/=2;
		}
		printf("Case #%d:\n",T++);
		for(i=0;i<k;i++)
		{
			printf("%d ",ans[i]);
			if(mark[i])
				printf("-\n");
			else
				printf("+\n");
		}
	}
	return 0;
}

//这是队友写的。
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<vector>
#include<algorithm>
#include<queue>
using namespace std;
const int INF=0x3f3f3f3f;
const double PI=acos(-1.0);
#define SI(x) scanf("%d",&x)
#define SL(x) scanf("%lld",&x)
#define PI(x) printf("%d",x)
#define PL(x) printf("%lld",x)
#define T_T while(T--)
#define P_ printf(" ")
#define mem(x,y) memset(x,y,sizeof(x))
typedef long long LL;
LL lowbit(LL x){return x&(-x);}
int sign[65];
int main()
{
	int kase=0;
	int T,K;
	LL N;
	SI(T);
	T_T
	{
		mem(sign,0);
		SL(N);SI(K);
		LL x=(1<<K)-N-1;
		if(x&1)
			x++;
		x/=2;
		int kk=1;
		while(x)
		{
			if(x&1ll)
				sign[kk]=1;
			kk++;
			x/=2;
		}
		printf("Case #%d:\n",++kase);
		for(int i=1;i<=K;i++)
		{
			if(i==K)
			{
				if(((1<<K)-N-1)&1)
					PL((1<<(i-1))+1),P_;
				else 
					PL(1<<(i-1)),P_;
			}
			else 
				PL(1<<(i-1)),P_;
			if(sign[i])
				puts("-");
			else 
				puts("+");
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值