hdoj A Simple Problem 4143 (数学求方程最小解)

A Simple Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 4910    Accepted Submission(s): 1254


Problem Description
For a given positive integer n, please find the smallest positive integer x that we can find an integer y such that y^2 = n +x^2.

Input
The first line is an integer T, which is the the number of cases.
Then T line followed each containing an integer n (1<=n <= 10^9).

Output
For each integer n, please print output the x in a single line, if x does not exit , print -1 instead.

Sample Input
  
  
2 2 3

Sample Output
  
  
-1 1
 
//将方程变换为:y^2-x^2=n;
=>(y-x)*(y+x)=n;
所以枚举所有的(y-x)然后不断更新最小值。
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int main()
{
	int t,n,i;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		int ans=INF;
		for(i=1;i<=sqrt(n);i++)
		{
			if(n%i==0)
			{
				int a=i;
				int b=n/i;
				if(b-a>0&&(b-a)%2==0)
				{
					int x=(b-a)/2;
					if(x<ans)
						ans=x;
				}
			}
		}
		if(ans==INF)
			printf("-1\n");
		else
			printf("%d\n",ans);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值