hdoj Least Common Multiple 1019 && 2028 (n个数的最小公倍数)

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41182    Accepted Submission(s): 15514


Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.


Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input
  
  
2 3 5 7 15 6 4 10296 936 1287 792 1

Sample Output
  
  
105 10296
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f
#define N 1010
#define ll long long
using namespace std;
int a[N];
ll gcd(ll x,ll y)
{
	ll t;
	if(x<y){t=x;x=y;y=t;}
	return y?gcd(y,x%y):x;
}
int main()
{
	int t,n,i,j;
	ll sum;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		sum=1;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			sum=sum*a[i]/gcd(sum,a[i]);
		}
		printf("%lld\n",sum);
	}
	return 0;
}

Lowest Common Multiple Plus

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45260 Accepted Submission(s): 18664


Problem Description
求n个数的最小公倍数。

Input
输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。

Output
为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。

Sample Input
     
     
2 4 6 3 2 5 7

Sample Output
     
     
12 70
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f
#define N 1010
#define ll long long
using namespace std;
int a[N];
ll gcd(ll x,ll y)
{
	ll t;
	if(x<y){t=x;x=y;y=t;}
	return y?gcd(y,x%y):x;
}
int main()
{
	int t,n,i,j;
	ll sum;
	while(scanf("%d",&n)!=EOF)
	{
		sum=1;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			sum=sum*a[i]/gcd(sum,a[i]);
		}
		printf("%lld\n",sum);
	}
	return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值