hdoj function 5608 (数学)

function

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 34    Accepted Submission(s): 7


Problem Description
There is a function f(x) ,which is defined on the natural numbers set N ,satisfies the following eqaution

N23N+2=d|Nf(d)

calulate Ni=1f(i) mod 109+7 .

Input
the first line contains a positive integer T,means the number of the test cases.

next T lines there is a number N


T500,N109

only 5 test cases has N>106 .

Output
T lines,each line contains a number,means the answer to the i -th test case.

Sample Input
  
  
1 3

Sample Output
  
  
2 $1^2-3*1+2=f(1)=0$ $2^2-3*2+2=f(2)+f(1)=0->f(2)=0$ $3^2-3*3+2=f(3)+f(1)=2->f(3)=2$ $f(1)+f(2)+f(3)=2$
//WA的代码:
可能是思路错了
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define ll long long
using namespace std;
const int M=1000000007;
int main()
{
	int t;
	ll sum,num;
	ll n,n1,n2;
	scanf("%d",&t);
	while(t--)
	{
		sum=0;
		scanf("%lld",&n);
		n1=(ll)(n*(n-1))%M;
		sum=(ll)(n1*(n-2))%M;
		sum=(ll)sum/3;
		printf("%lld\n",sum);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值