CodeForces - 675A Infinite Sequence (模拟)水

CodeForces - 675A
Time Limit:                                                        1000MS                        Memory Limit:                                                        262144KB                        64bit IO Format:                            %I64d & %I64u                       

Status

Description

Vasya likes everything infinite. Now he is studying the properties of a sequence s, such that its first element is equal to a (s1 = a), and the difference between any two neighbouring elements is equal to c (si - si - 1 = c). In particular, Vasya wonders if his favourite integer b appears in this sequence, that is, there exists a positive integer i, such that si = b. Of course, you are the person he asks for a help.

Input

The first line of the input contain three integers a, b and c ( - 109 ≤ a, b, c ≤ 109) — the first element of the sequence, Vasya's favorite number and the difference between any two neighbouring elements of the sequence, respectively.

Output

If b appears in the sequence s print "YES" (without quotes), otherwise print "NO" (without quotes).

Sample Input

Input
1 7 3
Output
YES
Input
10 10 0
Output
YES
Input
1 -4 5
Output
NO
Input
0 60 50
Output
NO

Sample Output

Hint

Source

//题意:输入a,b,c;
a表示序列的第一个元素的值s1,b是要找的元素的值,c是s(i)-s(i-1)的值,问b是否在这个序列中?
//思路:
直接模拟就行了
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
int main()
{
	int a,b,c;
	while(scanf("%d%d%d",&a,&b,&c)!=EOF)
	{
		int d=b-a;
		if(d==0)
		{
			printf("YES\n");
		}			
		else if(d>0)
		{
			if(c>0)
			{
				if(d%c==0)
					printf("YES\n");
				else
					printf("NO\n");
			}
			else
				printf("NO\n");
		}
		else
		{
			if(c<0)
			{
				if(d%c==0)
					printf("YES\n");
				else
					printf("NO\n");
			}
			else
				printf("NO\n");
		}
	}
	return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值