CodeForces - 675B Restoring Painting (暴力&转换)水

106 篇文章 0 订阅
25 篇文章 0 订阅
CodeForces - 675B
Time Limit:                                                        1000MS                        Memory Limit:                                                        262144KB                        64bit IO Format:                            %I64d & %I64u                       

Status

Description

Vasya works as a watchman in the gallery. Unfortunately, one of the most expensive paintings was stolen while he was on duty. He doesn't want to be fired, so he has to quickly restore the painting. He remembers some facts about it.

  • The painting is a square 3 × 3, each cell contains a single integer from 1 to n, and different cells may contain either different or equal integers.
  • The sum of integers in each of four squares 2 × 2 is equal to the sum of integers in the top left square 2 × 2.
  • Four elements a, b, c and d are known and are located as shown on the picture below.

Help Vasya find out the number of distinct squares the satisfy all the conditions above. Note, that this number may be equal to 0, meaning Vasya remembers something wrong.

Two squares are considered to be different, if there exists a cell that contains two different integers in different squares.

Input

The first line of the input contains five integers n, a, b, c and d (1 ≤ n ≤ 100 000, 1 ≤ a, b, c, d ≤ n) — maximum possible value of an integer in the cell and four integers that Vasya remembers.

Output

Print one integer — the number of distinct valid squares.

Sample Input

Input
2 1 1 1 2
Output
2
Input
3 3 1 2 3
Output
6

Sample Output

Hint

Source

//题意:
在一个九宫格里放区间[1,n]的任意一个值,现在告诉了你其中的四个值a,b,c,d,现在要求你填写完数字后使得所有的2*2的正方形格子里数的和都等于左上角的那个2*2的正方形格子里的值的和。
//思路:
首先得知道中间的那个数字是四个2*2方格公用的,所以不用考虑它,只考虑其他的几个就行了,然后直接暴力模拟就行了
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define ll long long
using namespace std;
int main()
{
	int n,a,b,c,d;
	while(scanf("%d%d%d%d%d",&n,&a,&b,&c,&d)!=EOF)
	{
		int num=0;
		for(int i=1;i<=n;i++)
		{
			int sum=a+b+i;
			if(sum-a-c<1||sum-a-c>n) continue;
			if(sum-b-d<1||sum-b-d>n) continue;
			if(sum-c-d<1||sum-c-d>n) continue;
			num++;
		}
		ll ans=(ll)n*(ll)num;
		printf("%lld\n",ans);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值