HDU - 4006 The kth great number (set&数据结构)

HDU - 4006
Time Limit:                                                        1000MS                        Memory Limit: 65768KB 64bit IO Format:                            %I64d & %I64u                       

Status

Description

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.      
               

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.       
               

Output

The output consists of one integer representing the largest number of islands that all lie on one line.       
               

Sample Input

    
    
8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
               

Sample Output

    
    
1 2 3

Hint

Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000). 
         
               

Source

The 36th ACM/ICPC Asia Regional Dalian Site —— Online Contest
//题意:
给你一个n,m,表示有n组输入,如果字母是I,输入一个数,否则表示询问第m大的数字是什么
//思路:
直接用multiset进行存放,当存放的数的个数大于m时就删除最后的那个,否则输出最后的那个数即可
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<set>
#define INF 0x3f3f3f3f
#define N 1000010
using namespace std;
char s[2];
struct zz
{
	int x;
	friend bool operator < (zz a,zz b)
	{
		return a.x>b.x;
	}
}p;
multiset<zz>st;
multiset<zz>::iterator f;
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		st.clear();
		for(int i=0;i<n;i++)
		{
			scanf("%s",s);
			if(s[0]=='I')
			{
				scanf("%d",&p.x);
				st.insert(p);
				f=st.end();
				f--;
				if(st.size()>m)
					st.erase(f);
			}
			else
			{
				f=st.end();
				f--;
				printf("%d\n",*f);		
			}	
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值