HDU 1518 Square(DFS)

Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".

Sample Input
3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5

Sample Output
yes
no

yes

题意:所有长度的木棍连起来能否组成一个正方形。

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;

int flag,sum,n;
int a[40],vis[40];
void dfs(int g,int l,int k)
{
    if(g==4)
    {
        flag=1;
        return;
    }
    if(l==sum)
    {
        dfs(g+1,0,0);
        if(flag)
        return;
    }
    for(int i=k; i<n; i++)
    {
        if(!vis[i]&&l+a[i]<=sum)
        {
            vis[i]=1;
            dfs(g,l+a[i],i+1);
            if(flag)
               return;
            vis[i]=0;
        }
    }
}
int main()
{
    int t,i;
    scanf("%d",&t);
    while(t--)
    {
        memset(vis,0,sizeof(vis));
        sum=0;
        flag=0;
        scanf("%d",&n);
        for(i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        if(sum%4!=0)
        {
            printf("no\n");
            continue;
        }
        for(i=0; i<n; i++)
            if(a[i]>sum)
                break;
        if(i!=n)
        {
            printf("no\n");
            continue;
        }
        sum=sum/4;
        dfs(0,0,0);
        if(flag)
            printf("yes\n");
        else
            printf("no\n");
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值