2010-5-25 Maximum Sum

Maximum Sum

 

今天有些无聊,就跑到jude online 上做做题,选的题目是 :

Maximum Sum

Time Limit: 15 Sec  Memory Limit: 128 MB
Submissions: 523  Solved: 41

Description

Given an integer array, how will you find out the increasing subsequence which gives the largest sum. For example,
4, 2, 1, 5, 3
in this subsequence a few possible increasing subsequences are
1) 4
2) 2
3) 1
4) 5
5) 3
6) 4, 5
7) 2, 5
8) 2, 3
9) 1, 5
10) 1, 3

but 4, 5 gievs the maximum sum.

Your task is how to find such the maximum sum in a given integer array.

Input

Multiply Cases, For each case:
The first line contains N(0< N <=1000000), which is the number of the integer array.
The second line contains N integer numbers not exceeding 2000000 by the absolute value.

Output

For each case, output only one integer, which is the maximum sum of increasing subsequences.

Sample Input

5

4 2 1 5 3

Sample Output

9











写完后,修改了几次,每次都是超时,有些郁闷,不过欣慰的是 至少做对了,只是速度太慢了,我最后的代码如下:



#include <stdio.h>

#define N 1000000

int main(){

int n = 0, i = 0, j = 0;
int data[N], rec[N], tmp = 0, max, maxn;

scanf("%d", &n);

    for(;i < n;i++){

scanf("%d", &data[i]);
rec[i] = data[i];
}

    max = rec[0];
maxn = 0;

for(i = 1; i <n; i ++){
for(j = i -1 ; j >= 0; j --){
if(data[j] < data[i]){
if(j == maxn){     
rec[i] = max + data[i];
max = rec[i];
maxn = i;
goto out;
}
             else{
if((tmp = rec[j] + data[i]) > rec[i]){
rec[i] = tmp;
}
             }
          }
     }

       if(rec[i] > max){
 max = rec[i];
maxn = i;
       }
out: ;
    }

  printf("%d", max);

    return 0;
}





希望高手看到后可以指点下,谢啦!



1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值