1086. Tree Traversals Again (25)

题目:

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
注意:
1、这个题目其实是1020的一个变型,这个题目中给出的其实是一个二叉树的前序(push得到)和中序序列(pop得到),然后重建该树。
2、一种方法是根据上面得到的两个序列来重构树,跟1020的思路是一样的。
3、在网上找到了另外一种更加简单的方法,通过递归把push的数据增添到树上,大家可以参考烟客旅人的个人网站http://tech-wonderland.net/blog/pat-1086-tree-traversals-again-solution-dfs-short-code.html。

代码:

//1086
#include<iostream>
using namespace std;

int n,i=0;

struct node
{
	int value;
	node *left;
	node *right;
	node(int v):value(v),left(NULL),right(NULL){}
}*root;

node * build()
{//build the tree
	if(i>=2*n)
		return NULL;
	char str[5];
	scanf("%s",str);
	node *root=NULL;
	++i;
	if(str[1]=='u')
	{//Push
		int val;
		scanf("%d",&val);
		root=new node(val);
		root->left=build();
		root->right=build();
	}
	return root;
}

void postorder(node *subroot)
{//print the postorder sequence
	if(subroot!=NULL)
	{
		postorder(subroot->left);
		postorder(subroot->right);
		printf("%d",subroot->value);
		if(subroot!=root)
			printf(" ");
	}
}

int main()
{
	scanf("%d",&n);
	root=build();
	postorder(root);
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值