HDU 3635 Dragon Balls

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5189    Accepted Submission(s): 1944


Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
 

Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 

Sample Input
  
  
2 3 3 T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1
 

Sample Output
  
  
Case 1: 2 3 0 Case 2: 2 2 1 3 3 2
 

Author
possessor WC
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   3172  3234  3639  3633  3638 
 读一遍题目之后,会很快想到并查集,但是移动次数输出有难度,也是最难理解的地方,

并且感觉自己对并查集还是不够熟悉
值得注意的是龙珠只向有龙珠的城市移动,所以每个城市的龙珠只移动一次
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int pre[11000]; 
int ran[11000];//城市龙珠的个数 
int num[11000];//龙珠移动的次数 
int find(int x)
{
	if(x==pre[x])
	return x;
	int f=pre[x];
	pre[x]=find(f);
	num[x]+=num[f];
	return pre[x];
}
void merge(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		pre[fx]=fy;
		ran[fy]+=ran[fx];//记录根节点的个数,即为每个城市龙珠的个数 
		num[fx]=1;//龙珠的第一次移动 
	}
}
void init()
{
	for(int i=0;i<11000;i++)
	{
		pre[i]=i;
		ran[i]=1;
		num[i]=0;
	}
}
int main()
{
	int t,n,i,q,a,b;
	char s[11];
	scanf("%d",&t);
	int k=1;
	while(t--)
	{
		scanf("%d%d",&n,&q);
		init();
		printf("Case %d:\n",k++);
		for(i=0;i<q;i++)
		{
			scanf("%s",s);
			if(s[0]=='T')
			{
				scanf("%d%d",&a,&b);
				merge(a,b);
			}
			else
			{
				scanf("%d",&a);
				int x=find(a);//a的根节点即为a所在的城市 
				printf("%d %d %d\n",x,ran[x],num[a]);
			}
		}
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值