HDU 2141 Can you find it?(二分)

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 23713    Accepted Submission(s): 5994


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO
 

Author
wangye
 

Source
 

Recommend

威士忌   |   We have carefully selected several similar problems for you:  2199 2899 2289 1551 1010 

题意:给出L个a,N个b,M个c ,输出X,问是否能找到一组a b c 使a+b+c=x;

思路:先合并两个数组,另外两个数组从小到大排序,对其中一根数组进行二分,

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int a[5500],b[5500],c[5500],d[31000000];
int main()
{
	int l,n,m,i,j,k,s;
	__int64 x;
	int t=1;
	while(scanf("%d%d%d",&l,&n,&m)!=EOF)
	{
		for(i=1;i<=l;i++)
		scanf("%d",&a[i]);
		for(i=1;i<=n;i++)
		scanf("%d",&b[i]);
		for(i=1;i<=m;i++)
		scanf("%d",&c[i]);
		k=1;
		for(i=1;i<=l;i++)
		for(j=1;j<=n;j++)
		d[k++]=a[i]+b[j];
		sort(d+1,d+k+1);
		scanf("%d",&s);
		printf("Case %d:\n",t++);
		while(s--)
		{
			scanf("%I64d",&x);
			bool flag=false;
			for(i=1;i<=m;i++)
			{
				int left=1;
				int right=k;
				while(left<=right)
				{
					int mid=(left+right)/2;
					if(c[i]+d[mid]==x)
					{
						flag=true;
						break;
					}
					else if(c[i]+d[mid]>x)
					{
						right=mid-1;
					}
					else
					{
						left=mid+1;
					}
				}
				if(flag)
				break;
			}
			if(flag)
			printf("YES\n");
			else
			printf("NO\n");
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值