HDU 5907 Find Q

Find Q

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 374    Accepted Submission(s): 204


Problem Description
Byteasar is addicted to the English letter 'q'. Now he comes across a string  S  consisting of lowercase English letters.

He wants to find all the continous substrings of  S , which only contain the letter 'q'. But this string is really really long, so could you please write a program to help him?
 

Input
The first line of the input contains an integer  T(1T10) , denoting the number of test cases.

In each test case, there is a string  S , it is guaranteed that  S  only contains lowercase letters and the length of  S  is no more than  100000 .
 

Output
For each test case, print a line with an integer, denoting the number of continous substrings of  S , which only contain the letter 'q'.
 

Sample Input
  
  
2 qoder quailtyqqq
 

Sample Output
  
  
1 7
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5910  5909  5908  5906  5905 
 
太坑了,在BC赛中输出没用%I64d 刚开始过了,后来却被hack。太亏了,掉了一大波分,下次就长记性了,要学会算时间复杂度。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	char s[110000];
	int t,i,j,k;
	__int64 l,r,m,n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s",s);
		int len=strlen(s);
		l=0;
		r=0;
		__int64 sum=0;
		for(i=0;i<len;i++)
		{
			if(s[i]=='q')
			{
				r++;
			}
			else
			{
				sum+=(r-l)*(1+r-l)/2;
				l=i;
				r=i;
			}
		}
		sum+=(r-l)*(1+r-l)/2; 
		printf("%I64d\n",sum);
	}
	return 0;
 } 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值