1200. Stick 匹配相同长度筷子

1200. Stick

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

 Anthony has collected a large amount of sticks for manufacturing chopsticks. In order to simplify his job, he wants to fetch two equal-length sticks for machining at a time. After checking it over, Anthony finds that it is always possible that only one stick is left at last, because of the odd number of sticks and some other unknown reasons. For example, Anthony may have three sticks with length 1, 2, and 1 respectively. He fetches the first and the third for machining, and leaves the second one at last. You task is to report the length of the last stick. 

Input

The input file will consist of several cases.   

Each case will be presented by an integer n (1<=n<=100, and n is odd) at first. Following that, n positive integers will be given, one in a line. These numbers indicate the length of the sticks collected by Anthony.   

The input is ended by n=0. 

Output

For each case, output an integer in a line, which is the length of the last stick. 

Sample Input

3
1
2
1
0

Sample Output

2

Problem Source

ZSUACM Team Member


#include <iostream>

using namespace std;

int main () {
	int n;
	int a[105] = {0};
	while (cin>>n && n) {
		int b;
		for (int i = 0; i < n; i++) {
			cin>>b;
			bool flag = false;
			for (int j = 0; j <= i; j++) {  //从头查找有没有跟新输入匹配的 如果有就把原来的设为0
				if (a[j] == b) {
					a[j] = 0;
					flag = true;
					break;
				}
			}
			if (flag == false)
				a[i] = b;
		}
		for (int i = 0; i < n; i++) { //把没匹配的输出
			if ( a[i]!= 0 )
				cout<<a[i]<<endl;
		}
	}
	//system("pause");
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
引用、、分别是关于配置Nginx Sticky模块的命令行示例。 Nginx Sticky模块是一个第三方模块,用于实现会话粘性。它通过将请求与相同的客户端IP进行关联,可以将多个请求分发给同一台后端服务器,从而实现会话保持。 在配置Nginx Sticky模块时,通常需要进行以下几个步骤: 1. 运行"./configure"命令,指定Nginx的安装路径和其他配置选项,如"--prefix"用于指定安装路径,"--add-module"用于指定Sticky模块的路径。、、的命令示例都包含了这一步骤。 2. 执行"make"命令,用于编译Nginx和Sticky模块的源代码。的命令示例包含了这一步骤。 需要注意的是,具体的配置命令可能会因为不同的环境和需求而有所差异,上述引用的命令只是示例,并非通用配置。在实际使用,需要根据自己的具体情况进行相应的配置。 请注意、、是与Nginx Sticky模块配置相关的命令行示例。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [Nginx搭载sticky模块保持回话](https://blog.csdn.net/u014225032/article/details/125417815)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] - *2* *3* [Nginx使用sticky模块实现对静态资源的Hash负载均衡](https://blog.csdn.net/dragonpeng2008/article/details/125704501)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值