POJ 1269 Intersecting Lines

B
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. 
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000. 

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT
 
   
 
   
 
   
 
   
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<iostream>
#define eps 1e-8
#define zero(x) (((x)>0?(x):-(x))<eps)

using namespace std;

struct point
{
    double x,y;
};

struct line
{
    point a,b;
} p,q;

double xmult(point p1,point p2,point p0)
{
    return (p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);
}
int dots_inline(point p1,point p2,point p3)
{
    return zero(xmult(p1,p2,p3));
}

int parallel(line u,line v)
{
    return zero((u.a.x-u.b.x)*(v.a.y-v.b.y)-(v.a.x-v.b.x)*(u.a.y-u.b.y));
}

point intersection(line u,line v)
{
    point ret=u.a;
    double t=((u.a.x-v.a.x)*(v.a.y-v.b.y)-(u.a.y-v.a.y)*(v.a.x-v.b.x))
             /((u.a.x-u.b.x)*(v.a.y-v.b.y)-(u.a.y-u.b.y)*(v.a.x-v.b.x));
    ret.x+=(u.b.x-u.a.x)*t;
    ret.y+=(u.b.y-u.a.y)*t;
    return ret;
}

int main()
{
    int n,m;
    int i,j;
    scanf("%d",&n);

    printf("INTERSECTING LINES OUTPUT\n");
    while(n--)
    {
        scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&q.a.x,&q.a.y,&q.b.x,&q.b.y,&p.a.x,&p.a.y,&p.b.x,&p.b.y);
        double k1 = (q.b.y - q.a.y)/(q.b.x - q.a.x);
        double k2 = (p.b.y - p.a.y)/(p.b.x - p.a.x);
        double b1,b2;
        b1 = q.b.y - (k1*q.b.x);
        b2 = p.b.y - (k2*p.b.x);
        if(parallel(q,p) == 1)
        {
            if(dots_inline(q.a,q.b,p.a)== 1)
            {
                printf("LINE\n");
            }
            else
            {

                printf("NONE\n");

            }
        }
        else
        {

            if((q.b.x-q.a.x) == 0 || (p.b.x-p.a.x) == 0)
            {
                if(q.b.x - q.a.x == 0)
                {
                    double yy = 0;
                    yy = k2*q.b.x + (p.b.y - k2*p.b.x);
                    printf("POINT %.2lf %.2lf\n",q.b.x,yy);
                }
                else
                {
                    double yy = 0;
                    yy = k1*p.b.x + (q.b.y - k1*q.b.x);
                    printf("POINT %.2lf %.2lf\n",p.b.x,yy);
                }
            }
            else
            {
                double xx,yy;
                xx=(k1*q.a.x-k2*p.a.x+p.a.y-q.a.y)/(k1-k2);
                yy=q.a.y+(xx-q.a.x)*k1;
                printf("POINT %.2lf %.2lf\n",xx,yy);
            }
        }
    }
    printf("END OF OUTPUT\n");

    return 0;
}

 
   
 
   
 
   
 
   
 
   
 
   
 
   
 
   
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<iostream>
#define eps 1e-8
#define zero(x) (((x)>0?(x):-(x))<eps)

using namespace std;

struct point
{
    double x,y;
};

struct line
{
    point a,b;
} p,q;

int panduan(line u,point w,point e)
{
    double aa,bb;
    aa = ((w.y*(u.b.x - u.a.x))-(w.x*(u.b.y - u.a.y))-(u.a.y*u.b.x)+(u.b.y*u.a.x));
    bb = ((e.y*(u.b.x - u.a.x))-(e.x*(u.b.y - u.a.y))-(u.a.y*u.b.x)+(u.b.y*u.a.x));
    if((aa>=0 && bb<=0) ||(aa<=0 && bb>=0))
    {
        return 1;
    }
    else
    {
        return 0;
    }
}
double xmult(point p1,point p2,point p0)
{
    return (p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);
}
int dots_inline(point p1,point p2,point p3)
{
    return zero(xmult(p1,p2,p3));
}

int parallel(line u,line v)
{
    return zero((u.a.x-u.b.x)*(v.a.y-v.b.y)-(v.a.x-v.b.x)*(u.a.y-u.b.y));
}

point intersection(line u,line v)
{
    point ret=u.a;
    double t=((u.a.x-v.a.x)*(v.a.y-v.b.y)-(u.a.y-v.a.y)*(v.a.x-v.b.x))
             /((u.a.x-u.b.x)*(v.a.y-v.b.y)-(u.a.y-u.b.y)*(v.a.x-v.b.x));
    ret.x+=(u.b.x-u.a.x)*t;
    ret.y+=(u.b.y-u.a.y)*t;
    return ret;
}
int main()
{
    int n,m;
    int i,j;
    scanf("%d",&n);

    printf("INTERSECTING LINES OUTPUT\n");
    while(n--)
    {
        scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&q.a.x,&q.a.y,&q.b.x,&q.b.y,&p.a.x,&p.a.y,&p.b.x,&p.b.y);
        double k1 = (q.b.y - q.a.y)/(q.b.x - q.a.x);
        double k2 = (p.b.y - p.a.y)/(p.b.x - p.a.x);
        double b1,b2;
        b1 = q.b.y - (k1*q.b.x);
        b2 = p.b.y - (k2*p.b.x);
        if(parallel(q,p) == 1)
        {
            if(dots_inline(q.a,q.b,p.a)== 1)
            {
                printf("LINE\n");
            }
            else
            {

                printf("NONE\n");

            }
        }
        else
        {
            point w;
            w = intersection(q,p);
            printf("POINT %.2lf %.2lf\n",w.x,w.y);
        }


    }
    printf("END OF OUTPUT\n");

    return 0;
}

 
   
 
   
 
   
 
  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值