POJ 1269 Intersecting Lines(判断两直线的位置关系)

Intersecting Lines

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect.
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

【思路分析】

   判断两直线的位置关系,要注意斜率不存在时的特殊情况,且当两直线斜率均不存在时有平行和重合两种情况,还有一点要注意的就是在OJ上交代码的时候用G++时输出格式应为%.2f而不是%.2lf。


代码如下:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;

int main()
{
    int n;
    //freopen("1.txt","r",stdin);
    scanf("%d",&n);
    printf("INTERSECTING LINES OUTPUT\n");
    while(n--)
    {
        int x1,x2,x3,x4,y1,y2,y3,y4;
        double k1,b1,k2,b2;
        double x,y;
        int flag = 0;//标记是否存在斜率不存在的直线
        bool first = false,second = false;//标记哪一条直线斜率不存在
        scanf("%d %d %d %d %d %d %d %d",&x1,&y1,&x2,&y2,&x3,&y3,&x4,&y4);
        if(x2 != x1)
        {
            k1 = (double)(y2 - y1) / (double)(x2 - x1);
            b1 = (double)y1 - k1 * x1;
        }
        else//斜率不存在
        {
            x = x1;
            flag++;
            first = true;
        }
        if(x3 != x4)
        {
            k2 = (double)(y4 - y3) / (double)(x4 - x3);
            b2 = (double)y3 - k2 * x3;
        }
        else
        {
            x = x3;
            flag++;
            second = true;
        }

        if(k1 == k2 && b1 == b2 || (flag == 2 && x1 == x3))//斜率不存在时也有重合的情况
        {
            printf("LINE\n");
            continue;
        }
        if(k1 == k2 && b1 != b2 || (flag == 2 && x1 != x3))//斜率不存在时也有平行的情况
        {
            printf("NONE\n");
            continue;
        }

        if(flag == 0)
        {
            x = (b2 - b1) / (k1 - k2);
            y = k1 * x + b1;
        }
        if(flag == 1)
        {
            if(first == true)//第一条直线不存在斜率
            {
                y = k2 * x + b2;
            }
            if(second == true)
            {
                y = k1 * x + b1;
            }
        }
        printf("POINT %.2f %.2f\n",x,y);

    }
    printf("END OF OUTPUT\n");
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值