HDU 5437 Alisha’s Party(模拟)

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1494    Accepted Submission(s): 401


Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value  v , and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let  p  people enter her castle. If there are less than  p  people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query  n  Please tell Alisha who the  nth  person to enter her castle is.
 

Input
The first line of the input gives the number of test cases,  T  , where  1T15 .

In each test case, the first line contains three numbers  k,m  and  q  separated by blanks.  k  is the number of her friends invited where  1k150,000 . The door would open m times before all Alisha’s friends arrive where  0mk . Alisha will have  q  queries where  1q100 .

The  ith  of the following  k  lines gives a string  Bi , which consists of no more than  200  English characters, and an integer  vi 1vi108 , separated by a blank.  Bi  is the name of the  ith  person coming to Alisha’s party and Bi brings a gift of value  vi .

Each of the following  m  lines contains two integers  t(1tk)  and  p(0pk)  separated by a blank. The door will open right after the  tth  person arrives, and Alisha will let  p  friends enter her castle.

The last line of each test case will contain  q  numbers  n1,...,nq  separated by a space, which means Alisha wants to know who are the  n1th,...,nqth  friends to enter her castle.

Note: there will be at most two test cases containing  n>10000 .
 

Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
 

Sample Input
  
  
1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3
 

Sample Output
  
  
Sorey Lailah Rose
 

Source



    题意:一个公主要举行生日party,n个朋友给她来过生日并且每个人都带了礼物,由于房间不够所以公主想了一个主意她开m此门,每次开门放p个人进来,进门的顺序按照每个人带来礼物的价值来决定,价值高的人优先进入,如果价值相同先来的人先进。然后后面有k次询问,每次询问输入一个数字x,输出第x个进入房间的人的名字
    ps:m次开门之后,如果门外还有人的话就等到当所有好友都来齐的时候进入,顺序还是按照礼物的价值大小。
   
   模拟水题:


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<queue>
#include<math.h>

using namespace std;

struct node{
     int x;
     int y;
     char name[210];
}p[150100];

struct node1{
    int x1;
    int y1;
}ai[151000];

bool operator < (const node &a, const node &b)
{
    if(a.x == b.x){
        return a.y>b.y;
    }
    return a.x < b.x;
}

int cmp(const void *a,const void *b){
    struct node1 *aa = (node1*)a;
    struct node1 *bb = (node1*)b;
    return aa->x1 - bb->x1;
}

priority_queue<node>q;

int n,m,k;
char Name[150100][210];
int w[150001];

int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d%d",&n,&m,&k);
        for(int i=1;i<=n;i++){
            scanf("%s%d",p[i].name,&p[i].x);
            p[i].y = i;
        }
        while(!q.empty()){
            q.pop();
        }
        int px = 0;
        int t = 1;
        for(int i=0;i<m;i++){
            scanf("%d%d",&ai[i].x1,&ai[i].y1);
        }
        qsort(ai,m,sizeof(ai[0]),cmp);
        struct node f;
        for(int ii=0;ii<m;ii++){
            int xx,yy;
            xx = ai[ii].x1;
            yy = ai[ii].y1;
            for(int i=xx;i>px;i--){
                q.push(p[i]);
            }
            while(yy){
                if(!q.empty()){
                    f = q.top();
                    q.pop();
                    strcpy(Name[t],f.name);
                    t++;
                }else{
                    break;
                }
                yy--;
            }
            px = xx;
        }
        for(int i=n;i>px;i--){
            q.push(p[i]);
        }
        while(!q.empty()){
            f = q.top();
            strcpy(Name[t],f.name);
            t++;
            q.pop();
        }
        for(int i=1;i<=k;i++){
            scanf("%d",&w[i]);
        }
        for(int i=1;i<=k;i++){
            if(i<k){
                printf("%s ",Name[w[i]]);
            }else{
                printf("%s",Name[w[i]]);
            }
        }
        printf("\n");
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值