UVa10474 Where is the Marble ? 有序数组二分找值,lower_bound / upper_bound

题意:

给出n个数,先把各数从小到大排序,然后q次询问xi在数组中的位置,不存在则输出相应信息。


输入样例:

4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0


输出样例:

CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3


//=======================================

数组从小到大有序。

lower_bound :查找“大于或者等于x”的第一个位置。

upper_bound:查找“大于x”的第一个位置。



#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 10000 + 5;
int a[maxn];

int main()
{
    int cas = 1, x;
    int n, q;
    while(~scanf("%d%d", &n, &q)) {
        if(n==0&&q==0) break;
        for(int i=1; i<=n; ++i) {
            scanf("%d", &a[i]);
        }
        sort(a+1, a+n+1);
        printf("CASE# %d:\n", cas++);
        while(q--){
            scanf("%d",&x);
            int p = lower_bound(a+1, a+n+1, x) - a;
            if(a[p]==x){ printf("%d found at %d\n", x, p);}
            else printf("%d not found\n", x);
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值