hdu1238 Substrings (暴力)


http://acm.hdu.edu.cn/showproblem.php?pid=1238

Substrings

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 10   Accepted Submission(s) : 6
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.

Input

The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string. 

Output

There should be one line per test case containing the length of the largest string found.

Sample Input

2
3
ABCD
BCDFF
BRCD
2
rose
orchid

Sample Output

2
2



直接枚举可能的字串,然后进行验证。

code:

#include <cstdio>
#include <cstring>
#include <string>
#include <iostream>
using namespace std;

string s[102];
int n;
bool check(string sub) {
    int i, j;
    string tmp;
    for(i=0; i<sub.size(); i++)
        tmp +=sub[ sub.size()-1-i];
    for(i=0; i<n; i++)
        if(s[i].find(sub)==s[i].npos && s[i].find(tmp)==s[i].npos)
            return false;
    return true;
}
void solve(int t,int p) {
    string sub;
    int i, j, k;
    int ans =0;
    for(i=0; i<t; i++)
        for(j=t-1; j>=i; j--) {
            if(j-i+1<ans) continue;
            sub = s[p].substr(i,j-i+1);
            if(check(sub)) {
                if(j-i+1>ans) ans = j-i+1;
            }
        }
    cout<<ans<<endl;
}
int main() {
   // freopen("in.txt","r",stdin);
    int T,i,t,sub_i, j;
    cin>>T;
    while(T--) {
        cin>>n;
        t = 200;
        for(i=0; i<n; i++) {
            cin>>s[i];
            if(s[i].size()<t) {
                t =s[i].size();
                sub_i = i;
            }
        }
        solve(t, sub_i);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值