杭电acm 4268 Alice and Bob set的运用

Alice and Bob

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3787 Accepted Submission(s): 1193


Problem Description
Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob's. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob's cards that Alice can cover.
Please pay attention that each card can be used only once and the cards cannot be rotated.


Input
The first line of the input is a number T (T <= 40) which means the number of test cases.
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice's card, then the following N lines means that of Bob's.


Output
For each test case, output an answer using one line which contains just one number.


Sample Input
2
2
1 2
3 4
2 3
4 5
3
2 3
5 7
6 8
4 1
2 5
3 4


Sample Output
1

2


解题思路:本题是一道运用set的简单题,首先从题意中我们可以了解到该题是求Alice的卡片能最大覆盖多少Bob的卡片。首先我们对Alice'和Bob的h进行从小到大的排序,然后再从1到n选取Bob的卡片中最接近Alice.y的卡片并删除。

代码如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <set>
#include <cstring>

using namespace std;

const int maxn = 100010;

struct node{
      int h,w;
      bool operator < (const node& b)const
      {
            return h<b.h;
      }
}a[maxn],b[maxn];

int t,n;
multiset<int> myset;
multiset<int>::iterator it;

int main()
{
      scanf("%d",&t);
      while(t--)
      {
            scanf("%d",&n);
            for(int i=1;i<=n;i++)
            {
                  scanf("%d %d",&a[i].h,&a[i].w);
            }
            for(int i=1;i<=n;i++)
                  scanf("%d %d",&b[i].h,&b[i].w);
            sort(a+1,a+1+n);
            sort(b+1,b+1+n);
            int j=1;
            int ans = 0;
            myset.clear();
            for(int i=1;i<=n;i++)
            {
                  while(j<=n && b[j].h <= a[i].h)
                  {
                        myset.insert(b[j].w);
                        j++;
                  }
                  it = myset.upper_bound(a[i].w);
                  if(myset.size()>0 && it!=myset.begin())   it--;
                  if(myset.size()>0 && (*it)<=a[i].w)
                  {
                        ans++;
                        myset.erase(it);
                  }
            }
            printf("%d\n",ans);
      }
      return 0;
}
本题需注意的地方:注意lower_bound和upper_bound的使用,详细用法见以下链接: lower_bound的使用


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值