UVA10014 Simple calculations


The Problem

There is a sequence of n+2 elements a0, a1,…, an+1 (n <= 3000; -1000 <=  ai 1000). It is known that ai = (ai–1 + ai+1)/2 – ci   for each i=1, 2, ..., n. You are given a0, an+1, c1, ... , cn. Write a program which calculates a1.

The Input

The first line is the number of test cases, followed by a blank line.

For each test case, the first line of an input file contains an integer n. The next two lines consist of numbers a0 and an+1 each having two digits after decimal point, and the next n lines contain numbers ci (also with two digits after decimal point), one number per line.

Each test case will be separated by a single line.

The Output

For each test case, the output file should contain a1 in the same format as a0 and an+1.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

1

1
50.50
25.50
10.15

Sample Output

27.85


题目的意思就是给出a0和an+1 还有c1,c2....cn。。。让你求a1。。
从公式中可以看出

a1 =  (a0 + a2 )/ 2 - c1
a2 = (a1 + a3) /2  - c2
.......
an = (an-1 + an+1) /2 -cn;

两边相加。消去相同项变得到
a1 + an = a0 + (an+1)  - 2*(c1 + c2 +......cn);
那么我们可以代入n得到一系列式子
a1 + a1 = a0 + a2 - 2*c1;
a1 + a2 = a0 + a3 - 2*(c1 + c2);
a1 + a3 = a0 + a4 - 2*(c1 + c2 +c3);
.......
a1 + an = a0 + (an+1)  - 2*(c1 + c2 +......cn);

还是相加 相消。。得到
(n+1)a1 = n*a0 +an+1 + 2(c1) + 2(c1 + c2) + 2(c1 + c2 + c3) ....... +2(c1 +c2 + c3.....+cn);
其中除了a1就都是以知的了。。就可以用它来求a1了!!

AC代码:

#include<stdio.h>

int main () {
	double T;
	double n;
	double a0,an1;
	double c[3010]; 
	double res = 0;
	scanf("%lf",&T);
//	printf("\n");
	while (T--) {
		res = 0 ;
		scanf("%lf",&n);
		scanf("%lf%lf",&a0,&an1);
		for (int i = 0; i < n ;i++) {
			scanf("%lf",&c[i]);
			res = res + (n -i) * c[i];
		}

		res = (n * a0 / (n + 1)) + (an1 /(n + 1)) - 2 * res /(n + 1)  ;
		printf("%.2lf\n",res);
		if(T)
			printf("\n");

	}


	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值