UVA 568 - Just the Facts

Description

Download as PDF The expression N!, read as `` N factorial," denotes the product of the first N positive integers, where N is nonnegative. So, for example,
NN!
01
11
22
36
424
5120
103628800

For this problem, you are to write a program that can compute the last non-zero digit of any factorial for ( $0 \le N \le 10000$). For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce ``2" because 5! = 120, and 2 is the last nonzero digit of 120.

Input 

Input to the program is a series of nonnegative integers not exceeding 10000, each on its own line with no other letters, digits or spaces. For each integer N, you should read the value and compute the last nonzero digit of N!.

Output 

For each integer input, the program should print exactly one line of output. Each line of output should contain the value N, right-justified in columns 1 through 5 with leading blanks, not leading zeroes. Columns 6 - 9 must contain `` -> " (space hyphen greater space). Column 10 must contain the single last non-zero digit of N!.

Sample Input 

1
2
26
125
3125
9999

Sample Output 

    1 -> 1
    2 -> 2
   26 -> 4
  125 -> 8
 3125 -> 2
 9999 -> 8





求n的阶层的最后一位不为0的数

每次不能单单只留最后一位数

因为可能下一位想成加起来能进一

所以要多保留几位

最少要保留五位数



#include <stdio.h>

int main(){
	int n, temp;
	while (scanf("%d", &n) != EOF) {
		long long m = 1;
		for (int i = 1; i <= n; i++) {
			temp = i;
			while (temp % 10 == 0)
				temp /= 10;
			m *= temp;
			while (m % 10 == 0)
				m /= 10;
			m = m % 100000;
		}
		printf("%5d -> %lld\n", n, m % 10);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值