PAT - 天梯赛 L2-012 关于堆的判断 (最小堆)

L2-012. 关于堆的判断

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • “x is the root”:x是根结点;
  • “x and y are siblings”:x和y是兄弟结点;
  • “x is the parent of y”:x是y的父结点;
  • “x is a child of y”:x是y的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(<= 1000)和M(<= 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[-10000, 10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出“T”,否则输出“F”。

输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10
输出样例:
F
T
F
T

思路: 这个题最小堆的创建, 父节点比左右子节点小就行,这个题 没进入一个数字就判断一次 是否比父节点小 若小则一直换到比父节点大为止 否则继续输入  

#include<cstdio>
#include<cstring>
#include<string>
#include<iostream>
using namespace std;

int ans[1005];  
int local[20005];  //存放最小堆中该值在ans中的位置
int main(){
	int n, m;
	cin >> n >> m;
	for(int i = 1; i <= n; i++){
		scanf("%d", &ans[i]);
		int x = i;
		local[ans[i] + 10000] = i;  // 因为是-10000到10000的区间 所以直接加10000
		while(x != 1 && ans[x/2] > ans[x]){
			swap(ans[x/2], ans[x]);
			local[ans[x/2] + 10000] = x/2;
			local[ans[x] + 10000] = x;
			x /= 2;
		}
	}
	for(int i = 1; i <= m; i++){
		string s;
		int a, b;
		cin >> a >> s;
		if(s[0] == 'a'){
			cin >> b >> s >> s;
			if(local[a + 10000] / 2 == local[b + 10000] / 2)
			    printf("T\n");
			else printf("F\n");
		}else{
			cin >> s;
			if(s[0] == 'a'){
				cin >> s >> s >> b;
				if(local[a + 10000] / 2 == local[b + 10000]) printf("T\n");
				else printf("F\n");
			}else{
				cin >> s;
				if(s[0] == 'r'){
					if(local[a + 10000] == 1) printf("T\n");
					else printf("F\n");
				}else{
					cin >> s >> b;
					if(local[b + 10000]/2 == local[a + 10000]) printf("T\n");
					else printf("F\n");
				}
			}
		}
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值