PAT (Advanced Level) Practice 1020 Tree Traversals (25 分)

  • 编程题

1020 Tree Traversals (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

题目大意:已知一棵树的后序和中序遍历,求层序遍历输出。

题解1:

思路:后序和中序转层序的典型题目

源代码1:

#include<iostream>
#include<stdlib.h>
#include<vector>
using namespace std;
int post[31], in[31], level[10001] = { 0 },maxidx=0;
void build(int r, int start, int end,int idx)
{
	if (start > end)return;
	int i=start;
	while (i <= end && in[i] != post[r])i++;
	level[idx] = post[r];
	if (maxidx < idx)maxidx = idx;
	build(r - end + i - 1, start, i - 1, idx * 2);
	build(r - 1, i+1, end, idx * 2 + 1);
	return;
}
struct node
{
	int left = -1, right = -1;
};
int main()
{
	int n, i, j, k, r;
	int q[31];
	scanf("%d", &n);
	for (i = 0; i < n; i++)
		scanf("%d", &post[i]);
	for (i = 0; i < n; i++)
		scanf("%d", &in[i]);
	r = post[n - 1];
	build(n - 1, 0, n - 1, 1);
	for (i = 1;i <= maxidx; i++)
	{
		if (level[i] != 0)
		{
			if (i == 1)printf("%d", level[i]);
			else printf(" %d", level[i]);
		}
	}
	system("pause");
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值