POJ 3187 Backward Digit Sum

Backward Digit Sums

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4281 Accepted: 2470

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 
 
    3   1   2   4

      4   3   6

        7   9

         16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

题意 

这个题意就是给你一个n和m,然后n个数排列后像上面的那样计算出一个数,如果和m想同就ok,输出最小的序列

 

 

 


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 20
int a[N], ans[N];
int vis[N];
int n, m;
int yes;
int  judge(int a[], int k) {
    if (k == 1)
        return a[0];
    for (int i = 0; i < n-1; i++) {
        a[i] = a[i] + a[i + 1];
    }
    return judge(a, k - 1);
}
void dfs(int pos) {
    if (yes == 1)
        return;
    if (pos == n) {
        for (int i = 0; i < n; i++) {
            a[i] = ans[i];//必须把ans数组转移到a数组中;
                         //因为下面是地址传递,会改变数组的值
        }
        if (judge(a, n) == m) {
            for (int i = 0; i < n; i++) {
                if (i == 0)
                    printf("%d", ans[i]);
                else
                    printf(" %d", ans[i]);
            }
            yes = 1;
        }
        return;
    }
    for (int i = 1; i <= n; i++) {
        if (!vis[i]) {
            vis[i] = 1;
            ans[pos] = i;
            dfs(pos + 1);
            vis[i] = 0;
        }
    }
}
int main() {
    cin >> n >> m;
    memset(vis, 0, sizeof(vis));
    yes = 0;
    for (int i = 1; i <= n; i++) {
        vis[i] = 1;
        ans[0] = i;
        dfs(1);
        vis[i] = 0;
    }
    return 0;
}

 

第二种解法  全排列  再搜索 (next_permutation)


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 20
int a[N], ans[N];
int vis[N];
int n, m;
int sum;
int yes;
int bang() {
	int k = n;//???????????
	for (int i = 1; i <= k; i++) {
		ans[i] = a[i];//全局变量的调用一定的要注意;
	}
	while (k> 1) {
		for (int i = 1; i < k; i++) {
			ans[i] = ans[i] + ans[i + 1];
		}
		k--;
	}
	return ans[1];
}
int main() {
	cin >> n >> m;
	sum = 0;
	yes = 0;
	for (int i = 1; i <= n; i++) {
		a[i] = i;
	}
	if (bang() == m) {
		yes = 1;
	}
	if (!yes)
	{
		while (next_permutation(a + 1, a + n + 1))
			if (bang() == m) {
				break;
			}
	}
	for (int i = 1; i <= n; i++) {
		if (i == 1)
			printf("%d", a[1]);
		else
			printf(" %d", a[i]);
	}
	return 0;
}

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值