题目1456:胜利大逃亡(广度优先搜索)

46 篇文章 0 订阅
46 篇文章 0 订阅
题目1456:胜利大逃亡

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:1118

解决:383

题目描述:

Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

输入:

输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙。

输出:

对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

样例输入:
1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0 
样例输出:
11
import java.util.LinkedList;
import java.util.Queue;
import java.util.Scanner;
 
public class Main{
 
    static int move[][] = {
        {0,0,1},
        {0,0,-1},
        {0,1,0},
        {0,-1,0},
        {1,0,0},
        {-1,0,0}
    };
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
        int time = scanner.nextInt();
        while( time-- != 0 ){
            int a = scanner.nextInt();
            int b = scanner.nextInt();
            int c = scanner.nextInt();
            int t = scanner.nextInt();
 
            boolean mark[][][] = new boolean[a][b][c];
            int migong[][][] = new int[a][b][c];
            for (int i = 0; i < a; i++) {
                for (int j = 0; j < b; j++) {
                    for (int k = 0; k < c; k++) {
                        mark[i][j][k] = false;
                        migong[i][j][k] = scanner.nextInt();
                    }
                }
            }
 
 
            Queue<Location> locationList = new LinkedList<Location>();
            Location now = new Location(0,0,0,0);
            locationList.add(now);
            mark[0][0][0] = true;
            int ans = -1;
             
            while(!locationList.isEmpty()){
                Location tmp = locationList.poll();
                 
                if(tmp.a == a-1 && tmp.b == b-1 && tmp.c == c-1 && tmp.t <= t){
                    System.out.println(tmp.t);
                    ans = 1;
                    break;
                }
                 
                for (int i = 0; i < 6; i++) {
                     
                    Location newLocation = move(tmp,move[i][0],move[i][1],move[i][2]);
                    if(newLocation.a<0||newLocation.b<0||newLocation.c<0||newLocation.a>=a||newLocation.b>=b||newLocation.c>=c)continue;
                    if(mark[newLocation.a][newLocation.b][newLocation.c] == true) continue;
                    if(migong[newLocation.a][newLocation.b][newLocation.c] == 1) continue;
                     
                    locationList.add(newLocation);
                    mark[newLocation.a][newLocation.b][newLocation.c] = true;
                }
            }
             
            if(ans == -1){
                System.out.println(ans);
            }
        }
    }
     
     
    public static class Location{
        int a;
        int b;
        int c;
        int t;
         
        public Location(int a,int b,int c,int t){
            this.a = a;
            this.b = b;
            this.c = c;
            this.t = t;
        }
         
        public Location(){
             
        }
    }
     
    public static Location move(Location now, int a,int b, int c){
        Location newLocation = new Location();
        newLocation.a = now.a+a;
        newLocation.b = now.b+b;
        newLocation.c = now.c+c;
        newLocation.t = now.t+1;
         
        return newLocation;
    }
 
}
 
/**************************************************************
    Problem: 1456
    User: yihukurama
    Language: Java
    Result: Accepted
    Time:710 ms
    Memory:106312 kb
****************************************************************/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值