【折半枚举】HDU_5616_Jam's balance

Jam's balance

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1830    Accepted Submission(s): 767


Problem Description
Jim has a balance and N weights.  (1N20)
The balance can only tell whether things on different side are the same weight.
Weights can be put on left side or right side arbitrarily.
Please tell whether the balance can measure an object of weight M.
 

Input
The first line is a integer  T(1T5) , means T test cases.
For each test case :
The first line is  N , means the number of weights.
The second line are  N  number, i'th number  wi(1wi100)  means the i'th weight's weight is  wi .
The third line is a number  M M  is the weight of the object being measured.
 

Output
You should output the "YES"or"NO".
 

Sample Input
  
  
1 2 1 4 3 2 4 5
 

Sample Output
  
  
NO YES YES
Hint
For the Case 1:Put the 4 weight alone For the Case 2:Put the 4 weight and 1 weight on both side
 

Source
 

Recommend
hujie
 
#include <bits/stdc++.h>
using namespace std;
const int maxn=31;
int a[maxn];
set<int>s1,s2,temp;
set<int>::iterator it;
int main()
{
    int t,n,q,x;
    scanf("%d",&t);
    while(t--){
        s1.clear();s2.clear();
        s1.insert(0);s2.insert(0);
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<n/2;i++){
            temp.clear();
            for(it=s1.begin();it!=s1.end();it++){
                temp.insert((*it)+a[i]);
                if((*it)-a[i]>=0)
                    temp.insert((*it)-a[i]);
                else temp.insert(a[i]-(*it));
            }
            for(it=temp.begin();it!=temp.end();it++)
                s1.insert((*it));
        }

        for(int i=n/2;i<n;i++){
            temp.clear();
            for(it=s2.begin();it!=s2.end();it++){
                temp.insert((*it)+a[i]);
                if((*it)-a[i]>=0)
                    temp.insert((*it)-a[i]);
                else temp.insert(a[i]-(*it));
            }
            for(it=temp.begin();it!=temp.end();it++)
                s2.insert((*it));
        }

        scanf("%d",&q);
        while(q--){
            scanf("%d",&x);
            if(x>2000){
                puts("NO");
                continue;
            }
            int f=0;
            for(int i=0;i<=x;i++){
                if(s1.find(i)!=s1.end()&&s2.find(x-i)!=s2.end()){
                    f=1;
                    break;
                }
            }
            if(f){
                puts("YES");
                continue;
            }
            for(int i=0;i<=2000;i++){
                if((s1.find(i)!=s1.end()&&s2.find(i+x)!=s2.end())
                ||(s2.find(i)!=s2.end()&&s1.find(i+x)!=s1.end())){
                    f=1;
                    break;
                }
            }
            if(f)
                puts("YES");
            else puts("NO");
        }
    }
    return 0;
}

#include <bits/stdc++.h>
using namespace std;
const int maxn=31;
int a[maxn];
vector<int>v;
bool vis[2010];
int main(){
    int t,n,q,x;
    scanf("%d",&t);
    while(t--){
        v.clear();
        memset(vis,false,sizeof(vis));
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            a[n+i]=-a[i];
        }
        v.push_back(0);
        for(int i=0;i<2*n;i++){
            int t=v.size();
            for(int j=0;j<t;j++){
                int temp=v[j]+a[i];
                if(temp>=0&&!vis[temp]){
                    vis[temp]=1;
                    v.push_back(temp);
                }
            }
        }
        scanf("%d",&q);
        while(q--){
            scanf("%d",&x);
            if(!vis[x])
                printf("NO\n");
            else printf("YES\n");
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值