PAT A1046. Shortest Distance (20)

该问题要求根据给定的高速公路环形出口之间的距离,计算任意两个出口间的最短距离。输入包含一个测试用例,首先给出出口数量N和它们之间的距离,然后是询问次数M,接着是M对出口编号,需计算这些出口对的最短距离。输出为每对出口的最短距离。
摘要由CSDN通过智能技术生成

PAT A1046. Shortest Distance (20)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7
#include <iostream>
#include <algorithm>
#include <vector>


using namespace std;




int main(){


    int n,m;

    cin>>n;

    vector<int> dis(n+10); 

    int sum=0;
    dis[0]=0;
    for(int i=1;i<=n;i++){

        int temp;
        cin>>temp;
        sum+=temp;
        dis[i]=sum; 


    }


    cin>>m;

    for(int i=0;i<m;i++){
        int start,end;
        cin>>start>>end;

        int dis1=0,dis2=0,res;

        if(start>end){
            swap(start,end);
        }

        dis1=dis[end-1]-dis[start-1];

        dis2=sum-dis1;

        res=min(dis1,dis2);


        cout<<res<<endl;



    }






    return 0;
}







这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值