POJ 2250 Compromise(最长公共子序列 列出子序列)

Compromise
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 8710
Accepted: 3703
Special Judge

Description

In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do. 

Therefore the German government requires a program for the following task: 
Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind). 

Your country needs this program, so your job is to write it for us.

Input

The input will contain several test cases. 
Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a line containing a single '#'. 
Input is terminated by end of file.

Output

For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.

Sample Input

die einkommen der landwirte
sind fuer die abgeordneten ein buch mit sieben siegeln
um dem abzuhelfen
muessen dringend alle subventionsgesetze verbessert werden
#
die steuern auf vermoegen und einkommen
sollten nach meinung der abgeordneten
nachdruecklich erhoben werden
dazu muessen die kontrollbefugnisse der finanzbehoerden
dringend verbessert werden
#

Sample Output

die einkommen der abgeordneten muessen dringend verbessert werden

Source

题目大意:
给出两段文字,求出最长的公共单词串
解题思路:
我们要把每一个单词作为一个整体。
在求出最长公共子序列的过程中,对其状态进行一个标记,然后通过状态的标记递归来输出最长公共子序列
以下是AC代码
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char a[105][35],b[105][35];
int dp[105][105],f[105][105];
void lcs(int len1,int len2){
	for(int i=1;i<=len1;i++){
		for(int j=1;j<=len2;j++){
			if(strcmp(a[i-1],b[j-1])==0){
				dp[i][j]=dp[i-1][j-1]+1;
				f[i][j]=1;
			}
			else{
				if(dp[i-1][j]>dp[i][j-1]){
				dp[i][j]=dp[i-1][j];
				f[i][j]=2;
			}
			else{
				dp[i][j]=dp[i][j-1];
				f[i][j]=3;
			}
			}
		}
	}
}
void dfs(int i,int j){
	if(i==0||j==0)return ;
	if(f[i][j]==1){
		dfs(i-1,j-1);
		printf("%s ",a[i-1]);
	}
	else if(f[i][j]==2){
		dfs(i-1,j);
	}
	else if(f[i][j]==3){
		dfs(i,j-1);
	}
}
int main(){
	while(~scanf("%s",a[0])){
		int len1=1;
		while(strcmp(a[len1-1],"#")){
			scanf("%s",a[len1++]);
		}
		len1--;
		scanf("%s",b[0]);
		int len2=1;
		while(strcmp(b[len2-1],"#")){
			scanf("%s",b[len2++]);
		}
		len2--;
		memset(dp,0,sizeof(dp));
		lcs(len1,len2);
		dfs(len1,len2);
		printf("\n");
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值